Closed Bug 1484593 Opened 2 years ago Closed 1 year ago

Selecting non-editable text causes extra text is selected

Categories

(Core :: Layout: Text and Fonts, defect, P3)

Unspecified
All
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- fix-optional

People

(Reporter: m_kato, Assigned: m_kato)

References

(Blocks 2 open bugs)

Details

(Keywords: regression)

When content is following that is nested contenteditable true and false and canret is after C, [Shift] + [Arrow right] selects "DEFG" instead of "DEF". 

<div contenteditable=true>ABC<div contenteditable=false>DEF</div>GHI</div>

It shouldn't select "G" at this operation.  If [Arrow right] only, caret can move to valid position correctly.  This might be regression by bug 989012's follow-up fix.
Just FTR, this appears to be an issue when the elements use display:inline, but I don't see it with display:block.

And [Shift/Left] suffers a similar issue when selecting in the other direction.
Priority: -- → P3
Happy to take a patch in nightly; if it seems low risk enough please feel free to request uplift to 65 beta.
I actually think this is fixed by bug 1506547. Makoto, can you confirm? If so, we should probably just land a test for this, though the test changes in there may cover this.
Flags: needinfo?(m_kato)
Thanks, I cannot reproduce this at the latest Nightly.
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(m_kato)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.