[de-xbl] Remove nobuttons binding

RESOLVED FIXED in Thunderbird 64.0

Status

enhancement
RESOLVED FIXED
Last year
Last year

People

(Reporter: arshad, Assigned: arshad)

Tracking

(Blocks 1 bug)

Trunk
Thunderbird 64.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.22 KB, patch
florian
: review+
Paenglab
: review+
mkmelin
: feedback+
Details | Diff | Splinter Review
No description provided.
Assignee: nobody → arshdkhn1
Status: NEW → UNCONFIRMED
Ever confirmed: false
Summary: [de-xbl] Remove nobutton binding → [de-xbl] Remove nobuttons binding
Posted patch nobuttons.patch (obsolete) — Splinter Review
Attachment #9002740 - Flags: review?(philipp)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Untriaged → Instant Messaging
Comment on attachment 9002740 [details] [diff] [review]
nobuttons.patch

This patch is in chat/ so philipp is not the correct reviewer.

The patch doesn't work though. Set up two accounts and notice the buttons do not go away once selecting another.

I think it would be useful to put your analysis of why you can remove it into the bug comments.
Attachment #9002740 - Attachment is obsolete: true
Attachment #9002740 - Flags: review?(philipp)
Thanks for taking a look at this! :florian or :nhnt11 can most likely review this for you. (I can as a last resort, they both know XBL/XUL much better than me!)
The bindings could be removed from both rules and then with:

richlistitem .account-buttons {
  display: none;
}
richlistitem[selected="true"] .account-buttons {
  display: -moz-box;
}

this should work.
Attachment #9006239 - Flags: review?(richard.marti)
Attachment #9006239 - Flags: review?(mkmelin+mozilla)
Attachment #9006239 - Flags: review?(richard.marti) → review+
Comment on attachment 9006239 [details] [diff] [review]
nobuttons.patch

Review of attachment 9006239 [details] [diff] [review]:
-----------------------------------------------------------------

Yep this works, thx!
Since this is chat/ maybe florian still wants to r+ it?
Attachment #9006239 - Flags: review?(mkmelin+mozilla)
Attachment #9006239 - Flags: review?(florian)
Attachment #9006239 - Flags: feedback+
Comment on attachment 9006239 [details] [diff] [review]
nobuttons.patch

r+ because the patch looks like it will work, but it's not obvious that this is an improvement. If the goal is to move away from xbl, it's the account.xml#account binding that you want to find a replacement for.
Attachment #9006239 - Flags: review?(florian) → review+
Well, one step at the time - this makes it one less thing to consider.
Status: NEW → ASSIGNED
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/7953345b93f6
Remove nobuttons binding. r=florian,Paenglab DONTBUILD
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
You need to log in before you can comment on or make changes to this bug.