Closed Bug 1485240 Opened 2 years ago Closed 2 years ago

Intermittent /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[R_ARROWRIGHT-expected4] - setup error

Categories

(Testing :: geckodriver, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1482550

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=195206818&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/S58uDnkWTOqlNZCwoQFYpw/runs/0/artifacts/public/logs/live_backing.log

[task 2018-08-22T02:35:04.058Z] 02:35:04     INFO - STDOUT: :473: UnknownErrorException
[task 2018-08-22T02:35:04.059Z] 02:35:04     INFO - STDOUT: =============================== warnings summary ===============================
[task 2018-08-22T02:35:04.059Z] 02:35:04     INFO - STDOUT: <undetermined location>
[task 2018-08-22T02:35:04.060Z] 02:35:04     INFO - STDOUT:   Module already imported so cannot be rewritten: mozlog
[task 2018-08-22T02:35:04.060Z] 02:35:04     INFO - STDOUT: -- Docs: http://doc.pytest.org/en/latest/warnings.html
[task 2018-08-22T02:35:04.061Z] 02:35:04     INFO - STDOUT: =============== 76 passed, 1 warnings, 2 error in 34.18 seconds ================
[task 2018-08-22T02:35:04.062Z] 02:35:04     INFO - 
[task 2018-08-22T02:35:04.062Z] 02:35:04     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[NUMPAD9-expected0] 
[task 2018-08-22T02:35:04.063Z] 02:35:04     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[RETURN-expected1] 
[task 2018-08-22T02:35:04.063Z] 02:35:04     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[HELP-expected2] 
[task 2018-08-22T02:35:04.063Z] 02:35:04     INFO - TEST-PASS | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[SHIFT-expected3] 
[task 2018-08-22T02:35:04.064Z] 02:35:04     INFO - TEST-UNEXPECTED-ERROR | /webdriver/tests/actions/special_keys.py | test_webdriver_special_key_sends_keydown[R_ARROWRIGHT-expected4] - setup error
[task 2018-08-22T02:35:04.064Z] 02:35:04     INFO - session = <Session db7b1c02-e920-46d2-94d6-1bbe6e1e97d0>
[task 2018-08-22T02:35:04.064Z] 02:35:04     INFO - test_actions_page = None
[task 2018-08-22T02:35:04.064Z] 02:35:04     INFO - request = <SubRequest 'key_reporter' for <Function 'test_webdriver_special_key_sends_keydown[R_ARROWRIGHT-expected4]'>>
[task 2018-08-22T02:35:04.065Z] 02:35:04     INFO - 
[task 2018-08-22T02:35:04.065Z] 02:35:04     INFO -     @pytest.fixture
[task 2018-08-22T02:35:04.065Z] 02:35:04     INFO -     def key_reporter(session, test_actions_page, request):
[task 2018-08-22T02:35:04.066Z] 02:35:04     INFO -         """Represents focused input element from `test_keys_page` fixture."""
[task 2018-08-22T02:35:04.066Z] 02:35:04     INFO - >       input_el = session.find.css("#keys", all=False)
[task 2018-08-22T02:35:04.066Z] 02:35:04     INFO - 
[task 2018-08-22T02:35:04.066Z] 02:35:04     INFO - request    = <SubRequest 'key_reporter' for <Function 'test_webdriver_special_key_sends_keydown[R_ARROWRIGHT-expected4]'>>
[task 2018-08-22T02:35:04.066Z] 02:35:04     INFO - session    = <Session db7b1c02-e920-46d2-94d6-1bbe6e1e97d0>
[task 2018-08-22T02:35:04.067Z] 02:35:04     INFO - test_actions_page = None
[task 2018-08-22T02:35:04.067Z] 02:35:04     INFO - 
[task 2018-08-22T02:35:04.067Z] 02:35:04     INFO - tests/web-platform/tests/webdriver/tests/actions/conftest.py:27:
Querying the full log file for an instance of `FindElement` with `#keys` I found the following:

[task 2018-08-22T02:34:31.561Z] 02:34:31     INFO - PID 1114 | [Parent 1126, Gecko_IOThread] WARNING: pipe error (93): Connection reset by peer: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 356
[task 2018-08-22T02:34:31.561Z] 02:34:31     INFO - PID 1114 | 
[task 2018-08-22T02:34:31.561Z] 02:34:31     INFO - PID 1114 | ###!!! [Parent][MessageChannel] Error: (msgtype=0x190080,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
[task 2018-08-22T02:34:31.562Z] 02:34:31     INFO - PID 1114 | 
[task 2018-08-22T02:34:31.562Z] 02:34:31     INFO - PID 1114 | 
[task 2018-08-22T02:34:31.563Z] 02:34:31     INFO - PID 1114 | ###!!! [Parent][MessageChannel] Error: (msgtype=0x190080,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
[task 2018-08-22T02:34:31.563Z] 02:34:31     INFO - PID 1114 | 
[task 2018-08-22T02:34:31.585Z] 02:34:31     INFO - PID 1114 | 1534905271579	Marionette	DEBUG	[20] Frame script loaded
[task 2018-08-22T02:34:31.586Z] 02:34:31     INFO - PID 1114 | 1534905271579	Marionette	DEBUG	[20] Frame script registered
[task 2018-08-22T02:34:31.606Z] 02:34:31     INFO - PID 1114 | A content process crashed and MOZ_CRASHREPORTER_SHUTDOWN is set, shutting down

Means we have a content crash again, which doesn't result in a stack trace to be printed. I filed bug 1485259 to get this investigated for wptrunner.
Depends on: 1485259
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1482550
You need to log in before you can comment on or make changes to this bug.