Closed Bug 1485663 Opened 2 years ago Closed 2 years ago

Turning off "Open links in tabs instead of new windows" causes blank window when clicking link in another app

Categories

(Firefox :: Tabbed Browser, defect)

63 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1485577
Tracking Status
firefox63 --- affected

People

(Reporter: mjf, Unassigned)

References

Details

Steps to reproduce:
- Open Nightly with a fresh profile.  I've only verified on OSX 10.12.6 so far with 63.0a1 (2018-08-23) (64-bit).
- Go to about:preferences and turn off "Open links in tabs instead of new windows"
- Click a link in another app (from email in Mail.app as an example)
- See empty new browser window (as if New Window was selected) instead of loaded page for link.

It is not URL specific.  I ran mozregression, and it pinpointed the following pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3d50f935615c9ba9179e8ab0dbb244ca65626967&tochange=486f7f825c6bfb4b31cb76c49174f2880dd8af19

Turning on "Open links in tabs instead of new windows" causes the sames links to open and load content in new tabs.  This is the only setting change required to cause the incorrect behavior.
Blocks: 1364392
I think this could be a possible dupe of Bug 1485577 but easier to test on linux.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1485577
You need to log in before you can comment on or make changes to this bug.