Closed Bug 1485810 Opened Last year Closed Last year

LastPass, 1Password, Bitwarden and all 3rd-party password manager auto-fill is broken in Firefox for Android

Categories

(Firefox for Android :: Logins, Passwords and Form Fill, defect, major)

50 Branch
ARM
Android
defect
Not set
major

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- fixed

People

(Reporter: jchen, Assigned: jchen)

References

(Blocks 3 open bugs)

Details

(Keywords: regression)

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1330257 +++

In Firefox 49, LastPass worked with Firefox for Android (albeit in a limited fashion, requiring you to copy/paste usernames/passwords, as opposed to them actually being filled in like with Chrome and other Android applications).

In Firefox 50, LastPass doesn't work at all. If you tap the LastPass notification, it just displays a toast that reads 'LastPass was unable to auto-fill this app'.

Putting this in Keyboards/IME but uncertain of the mechanism LastPass actually uses to auto-fill applications.
Move all auto-fill code to GeckoViewAutoFill.jsm, so they can be shared
between GeckoView and Fennec.
Make auto-fill work for the main Fennec activity by making calls to
GeckoViewAutoFill.
Comment on attachment 9005759 [details]
Bug 1485810 - 2. Add GeckoViewAutoFill support in browser.js; r?petru

Petru-Mugurel Lingurar[:petru] has approved the revision.
Attachment #9005759 - Flags: review+
Comment on attachment 9005758 [details]
Bug 1485810 - 1. Move auto-fill code to GeckoViewAutoFill.jsm; r?droeh

Dylan Roeh (:droeh) has approved the revision.
Attachment #9005758 - Flags: review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d59d980a5745
1. Move auto-fill code to GeckoViewAutoFill.jsm; r=droeh
https://hg.mozilla.org/integration/mozilla-inbound/rev/32efa2eb33bd
2. Add GeckoViewAutoFill support in browser.js; r=petru
https://hg.mozilla.org/mozilla-central/rev/d59d980a5745
https://hg.mozilla.org/mozilla-central/rev/32efa2eb33bd
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Question about this issue: In the current Aurora build, we can now see the individual fields inside the browser, but they are all the same size and position as the containing ViewGroup, which is causing problems with field classification. Will there be an update to correct this?
Depends on: 1491989
(In reply to Anatoly from comment #7)
> Question about this issue: In the current Aurora build, we can now see the
> individual fields inside the browser, but they are all the same size and
> position as the containing ViewGroup, which is causing problems with field
> classification. Will there be an update to correct this?

Thanks for the problem report! I filed new bug 1491989 to track this regression. If you have specific steps to reproduce or a link to a test case, please share it in that bug.
Blocks: 1491989
No longer depends on: 1491989
Did we want to let this ride the trains?
Flags: needinfo?(nchen)
I think so, since this bug involves only Fennec.
Flags: needinfo?(nchen)
Depends on: 1492704
Tested on Nightly 64.0a1 with the following 3rd-party password managers: LastPass, 1Password, Bitwarden using the following devices: 
- Motorola Nexus 6(Android 7.1.1), 
- LG G4(Android 5.1),
- Sony Xperia Z5 Premium (Android 6.0.1).
I was able to log in on several sites (Twitter, Facebook) using 1Password and Bitwarden but with no success regarding LastPass. Tested also on Chrome to see if is some setting the problem but it worked just fine.
Hey Anotoly,

The latest nightly build should be giving you real screen coordinates of the edit boxes. As Sorina says, we still can't get LastPass to work via the a11y api. Does this have to do with failed URL scraping from the toolbar?

In uitautomator I can see a TextView with an id of #PACKAGENAME#:id/url_bar_title with the text value being the current URL. Shouldn't that be enough?

Thanks!
Flags: needinfo?(anatoly)
Hi Eitan,

Our current production build does not support Nightly; I will email you a develop build for testing.

I have confirmed in uiautomatorviewer that the coordinates appear to be correct, and a11y autofill works. However it looks like the autofill framework is still not seeing coordinates, and pinning the autofill window to the bottom on Pie.

Thanks,
Anatoly
Flags: needinfo?(anatoly)
Thanks Anatoly,

The autofill API has a different non-a11y implementation, so we will need to add coordinates there as well.
Depends on: 1504257
Duplicate of this bug: 1512858
You need to log in before you can comment on or make changes to this bug.