Closed Bug 1486067 Opened 6 years ago Closed 6 years ago

Crash in static void core::option::expect_failed | static void webrender::prim_store::PrimitiveStore::prepare_prim_runs

Categories

(Core :: Graphics: WebRender, defect, P3)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox62 --- unaffected
firefox63 --- disabled

People

(Reporter: marcia, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-c7c37884-03be-4672-a169-c35d70180822.
=============================================================

Seen while looking at nightly crash stats: https://bit.ly/2BJh35p. Fairly low volume crash which might be a result of the recent webrender update, Bug 1481570.

Top 10 frames of crashing thread:

0 xul.dll static void std::panicking::rust_panic_with_hook src/libstd/panicking.rs:521
1 xul.dll static void std::panicking::continue_panic_fmt src/libstd/panicking.rs:426
2 xul.dll static void std::panicking::rust_begin_panic src/libstd/panicking.rs:337
3 xul.dll static void core::panicking::panic_fmt src/libcore/panicking.rs:92
4 xul.dll static void core::option::expect_failed src/libcore/option.rs:960
5 xul.dll static void webrender::prim_store::PrimitiveStore::prepare_prim_runs gfx/webrender/src/prim_store.rs:1834
6 xul.dll static union core::option::Option<euclid::rect::TypedRect<f32, webrender_api::units::LayoutPixel>> webrender::prim_store::PrimitiveStore::prepare_prim_for_render gfx/webrender/src/prim_store.rs:1562
7 xul.dll static void webrender::prim_store::PrimitiveStore::prepare_prim_runs gfx/webrender/src/prim_store.rs:1819
8 xul.dll static union core::option::Option<euclid::rect::TypedRect<f32, webrender_api::units::LayoutPixel>> webrender::prim_store::PrimitiveStore::prepare_prim_for_render gfx/webrender/src/prim_store.rs:1562
9 xul.dll static void webrender::prim_store::PrimitiveStore::prepare_prim_runs gfx/webrender/src/prim_store.rs:1819

=============================================================
Some similar bugs, Bug 1480400 and Bug 1418813 which are both a bit older than this one.
(In reply to Marcia Knous [:marcia - needinfo? me] from comment #0)
> bp-c7c37884-03be-4672-a169-c35d70180822.

> MOZ_CRASH Reason 	invalid parent!
The crash reason has been added by bug 1483303 ( servo/webrender#2972 ).
Only crashed on one day, did you fix this, glenn?
Flags: needinfo?(gwatson)
Priority: -- → P3
Not that I'm specifically aware of, but lots has changed around there recently which may have incidentally fixed it.
Flags: needinfo?(gwatson)
Closing because no crashes reported for 12 weeks.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.