Closed Bug 1487060 Opened 2 years ago Closed 2 years ago

The User is not Redirected to the Content Blocking section in RTL builds

Categories

(Firefox :: Preferences, defect, P2)

Unspecified
All
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox63 --- affected

People

(Reporter: rares.doghi, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: rtl, Whiteboard: [privacy-panel-64])

[Affected versions]: 
Nightly 63.0a1

[Affected platforms]:
Platforms: Windows 10 x64, Windows 10 x86, Mac OS X 10.13, Ubuntu 16.04 x64

Preconditions :


[Steps to reproduce]:
1. Open the RTL arabic Firefox Browser.
2. Reach the reddit.com web page.
3. Open the Hamburger menu and click the Content Blocking button.
4. Click the Show Site Information and click the Open Tracking Protection Preferences.

Expected Result:
The About:Preferences#Privacy should open in a new tab and the user should be redirected to the Content Blocking section.
Please note that the Content Blocking section should be highlighted.

Actual Results:
The about:preferences#privacy tab is opened but the page does not scroll down to the Content Blocking section.
Blocks: 1484622
Blocks: privacy-ui
No longer blocks: 1484622
Summary: [Fastblock] The User is not Redirected to the Content Blocking section in RTL builds → The User is not Redirected to the Content Blocking section in RTL builds
Priority: -- → P3
Priority: P3 → P2
Whiteboard: [privacy-panel-64]
Blocks: 1475097
Keywords: rtl
Sounds more like a preferences issue...
Component: Tracking Protection → Preferences
This is not a valid bug.  On the Arabic build, this code is throwing because of a missing string in the translation <https://searchfox.org/mozilla-central/rev/5a18fb5aeeec99f1ca1c36a697082c221189a3b9/browser/extensions/formautofill/FormAutofillPreferences.jsm#93> which means the initialization steps for the Preferences window isn't being run to completion.  The same problem occurs in any localized build without a translation for autofillAddressesCheckbox.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.