Closed Bug 1487278 Opened Last year Closed Last year

Intermittent PID 11358 | Assertion failure: transceiver->IsAssociated() (ICE candidate was gathered before the transceiver was associated! This should never happen.) at /builds/worker/workspace/build/src/media/webrtc/signaling/src/jsep/JsepSessionImpl.cpp

Categories

(Core :: WebRTC, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- wontfix
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: bwc)

References

Details

(Keywords: assertion, intermittent-failure)

Attachments

(1 file)

Filed by: csabou [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=196532731&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/Q8lzC8G9StaGtDVKYyCwRA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-08-29T23:10:22.761Z] 23:10:22     INFO - PID 11358 | (ice/WARNING) ICE(PC:1535584222090495 (id=4294967543 url=https://web-platform.test:8443/webrtc/RTCRtpTransceiver.https.html)): local addresses already set, no work to do
[task 2018-08-29T23:10:22.762Z] 23:10:22     INFO - PID 11358 | [Child 11444: Socket Thread]: I/signaling [Socket Thread|MediaPipeline] MediaPipeline.cpp:731: a32bea1a82121ea1| Transmit audio[{b92886af-12c9-43ac-aa01-047c6c84adc9}] in DetachTransport_s
[task 2018-08-29T23:10:22.763Z] 23:10:22     INFO - PID 11358 | [Child 11444: Socket Thread]: I/signaling [Socket Thread|MediaPipeline] MediaPipeline.cpp:731: a32bea1a82121ea1| Receive audio in DetachTransport_s
[task 2018-08-29T23:10:22.764Z] 23:10:22     INFO - PID 11358 | [Child 11444: Main Thread]: I/signaling [main|sdp_config] sdp_config.c:86: SDP: Initialized config pointer: 0xe05821c0
[task 2018-08-29T23:10:22.765Z] 23:10:22     INFO - PID 11358 | [Child 11444: Main Thread]: I/jsep [1535584222193367 (id=4294967543 url=https://web-platform.test:8443/webrtc/RTCRtpTransceiver.https.html)]: stable -> have-remote-offer
[task 2018-08-29T23:10:22.765Z] 23:10:22     INFO - PID 11358 | [Child 11444: Socket Thread]: I/signaling [Socket Thread|MediaPipeline] MediaPipeline.cpp:731: ca705f3cb34b64c1| Transmit audio[{b92886af-12c9-43ac-aa01-047c6c84adc9}] in DetachTransport_s
[task 2018-08-29T23:10:22.767Z] 23:10:22     INFO - PID 11358 | [Child 11444: Socket Thread]: I/signaling [Socket Thread|MediaPipeline] MediaPipeline.cpp:731: ca705f3cb34b64c1| Receive audio in DetachTransport_s
[task 2018-08-29T23:10:22.767Z] 23:10:22     INFO - PID 11358 | Assertion failure: transceiver->IsAssociated() (ICE candidate was gathered before the transceiver was associated! This should never happen.), at /builds/worker/workspace/build/src/media/webrtc/signaling/src/jsep/JsepSessionImpl.cpp:2246
[task 2018-08-29T23:10:22.784Z] 23:10:22     INFO - PID 11358 | #01: mozilla::JsepSessionImpl::AddLocalIceCandidate(std::string const&, std::string const&, unsigned short*, std::string*, bool*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.792Z] 23:10:22     INFO - PID 11358 | #02: mozilla::PeerConnectionImpl::CandidateReady(std::string const&, std::string const&) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.795Z] 23:10:22     INFO - PID 11358 | #03: sigslot::_connection2<mozilla::PeerConnectionImpl, std::string const&, std::string const&, sigslot::single_threaded>::emit(std::string const&, std::string const&) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.803Z] 23:10:22     INFO - PID 11358 | #04: sigslot::signal2<std::string const&, std::string const&, sigslot::single_threaded>::operator()(std::string const&, std::string const&) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.805Z] 23:10:22     INFO - PID 11358 | #05: mozilla::PeerConnectionMedia::OnCandidateFound_m(std::string const&, std::string const&, unsigned short, std::string const&, unsigned short, std::string const&) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.813Z] 23:10:22     INFO - PID 11358 | #06: mozilla::runnable_args_memfn<mozilla::PeerConnectionMedia*, void (mozilla::PeerConnectionMedia::*)(std::string const&, std::string const&, unsigned short, std::string const&, unsigned short, std::string const&), std::string, std::string, unsigned short, std::string, unsigned short, std::string>::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.817Z] 23:10:22     INFO - PID 11358 | #07: nsThread::ProcessNextEvent(bool, bool*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.825Z] 23:10:22     INFO - PID 11358 | #08: NS_ProcessNextEvent(nsIThread*, bool) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.828Z] 23:10:22     INFO - PID 11358 | #09: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.832Z] 23:10:22     INFO - PID 11358 | #10: MessageLoop::RunInternal() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.840Z] 23:10:22     INFO - PID 11358 | #11: MessageLoop::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.844Z] 23:10:22     INFO - PID 11358 | #12: nsBaseAppShell::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.852Z] 23:10:22     INFO - PID 11358 | #13: XRE_RunAppShell() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.853Z] 23:10:22     INFO - PID 11358 | #14: mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.854Z] 23:10:22     INFO - PID 11358 | #15: MessageLoop::RunInternal() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.856Z] 23:10:22     INFO - PID 11358 | #16: MessageLoop::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.860Z] 23:10:22     INFO - PID 11358 | #17: XRE_InitChildProcess(int, char**, XREChildData const*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.863Z] 23:10:22     INFO - PID 11358 | #18: mozilla::BootstrapImpl::XRE_InitChildProcess(int, char**, XREChildData const*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-08-29T23:10:22.929Z] 23:10:22     INFO - PID 11358 | #19: main (/builds/worker/workspace/build/application/firefox/firefox)
[task 2018-08-29T23:10:23.026Z] 23:10:23     INFO - PID 11358 | ###!!! [Parent][MessageChannel] Error: (msgtype=0x190080,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
[task 2018-08-29T23:10:23.043Z] 23:10:23     INFO - PID 11358 | ###!!! [Parent][MessageChannel] Error: (msgtype=0x190080,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
[task 2018-08-29T23:10:23.044Z] 23:10:23     INFO - PID 11358 | ++DOCSHELL 0xdeb53800 == 6 [pid = 11358] [id = {25bc712e-e992-424d-a0ef-50bd4b6edf4f}]
[task 2018-08-29T23:10:23.045Z] 23:10:23     INFO - PID 11358 | ++DOMWINDOW == 11 (0xdf58e700) [pid = 11358] [serial = 17] [outer = (nil)]
[task 2018-08-29T23:10:23.061Z] 23:10:23     INFO - PID 11358 | ++DOMWINDOW == 12 (0xdf9bb000) [pid = 11358] [serial = 18] [outer = 0xdf58e700]
[task 2018-08-29T23:10:23.150Z] 23:10:23     INFO - PID 11358 | ###!!! [Parent][MessageChannel] Error: (msgtype=0x190080,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
[task 2018-08-29T23:10:23.166Z] 23:10:23     INFO - PID 11358 | ++DOCSHELL 0xe0472400 == 7 [pid = 11358] [id = {8a66f03d-e0f5-4e8d-9745-a4ecbdddcbed}]
[task 2018-08-29T23:10:23.168Z] 23:10:23     INFO - PID 11358 | ++DOMWINDOW == 13 (0xdf5c4ca0) [pid = 11358] [serial = 19] [outer = (nil)]
[task 2018-08-29T23:10:23.169Z] 23:10:23     INFO - PID 11358 | ++DOMWINDOW == 14 (0xe0475c00) [pid = 11358] [serial = 20] [outer = 0xdf5c4ca0]
[task 2018-08-29T23:10:23.234Z] 23:10:23     INFO - PID 11358 | A content process crashed and MOZ_CRASHREPORTER_SHUTDOWN is set, shutting down
[task 2018-08-29T23:10:23.251Z] 23:10:23     INFO - PID 11358 | JavaScript error: resource://activity-stream/lib/TopSitesFeed.jsm, line 86: TypeError: setting getter-only property "_currentSearchHostname"
[task 2018-08-29T23:10:23.334Z] 23:10:23     INFO - PID 11358 | ++DOMWINDOW == 15 (0xe0965c00) [pid = 11358] [serial = 21] [outer = 0xdf58e700]
[task 2018-08-29T23:10:23.455Z] 23:10:23     INFO - PID 11358 | ++DOMWINDOW == 16 (0xdf9b3000) [pid = 11358] [serial = 22] [outer = 0xdf5c4ca0]
[task 2018-08-29T23:10:23.674Z] 23:10:23     INFO - PID 11358 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2018-08-29T23:10:23.675Z] 23:10:23     INFO - PID 11358 | [Child 11417, Main Thread] WARNING: NS_ENSURE_TRUE(maybeContext) failed: file /builds/worker/workspace/build/src/xpcom/threads/nsThread.cpp, line 866
Duplicate of this bug: 1502992
Assignee: nobody → docfaraday
I think I know what is happening here, but I'm not 100% sure. It seems likely that we are seeing a race where a transceiver is stopped (and disassociated) due to a remote description, while a local trickle candidate is in flight from STS to main. I think the right thing to do here is just ignore such candidates.
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ade9fff502f6
When a transceiver is stopped/disassociated by a remote description, clear its transport id too. r=mjf
https://hg.mozilla.org/mozilla-central/rev/ade9fff502f6
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Please nominate this for Beta uplift when you get a chance.
Flags: needinfo?(docfaraday)
Keywords: assertion
Comment on attachment 9024758 [details]
Bug 1487278: When a transceiver is stopped/disassociated by a remote description, clear its transport id too.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1483338

User impact if declined: Intermittent failures in webrtc wpt.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): This is a very minor tweak.

String changes made/needed: None
Flags: needinfo?(docfaraday)
Attachment #9024758 - Flags: approval-mozilla-beta?
Comment on attachment 9024758 [details]
Bug 1487278: When a transceiver is stopped/disassociated by a remote description, clear its transport id too.

small webrtc fix, approved for 64.0b12
Attachment #9024758 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.