Closed Bug 14874 Opened 21 years ago Closed 20 years ago

[Feature] Each edit control needs a context menu

Categories

(Core :: DOM: Navigation, defect, P1, major)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: jcarpenter0524, Assigned: Brade)

References

Details

(Whiteboard: [nsbeta2+][6/15])

Overview Description:
Can't bring up a right click menu in the location bar

Steps to Reproduce:
- put mouse cursor in location bar and right click


Actual Results:
nothing happens

Expected Results:
I expect to see the edit menu come up (undo, cut, copy, paste, etc.)

Build Date & Platform Bug Found:
1999092112 Win98
I've seen this for a while, but thought it was reported.
Assignee: troy → buster
Component: Layout → Editor
I think the location bar is Ender, so I guess this would be an editor bug?
Assignee: buster → sfraser
OS: Windows 98 → All
Hardware: PC → All
Summary: [PP] no right click menu for location bar → [Feature] no right click menu for location bar
context menus are not yet implemented.  When they are, it'll be the browser that
brings up the context menu in conjunction with the editor.  Assigned to simon.
I think the XPApps team would hook up this context menu.
Assignee: sfraser → don
Summary: [Feature] no right click menu for location bar → [Feature] need context menu for location bar
Summary: [Feature] need context menu for location bar → [Feature] edit controls need context menu
On Netscape 4.x under Windows, all edit controls have a [Undo | Cut Copy Paste
Delete | Select All ] menu.   This includes edit controls in the chrome and edit
controls in html forms.
Summary: [Feature] edit controls need context menu → [Feature] Each edit control needs a context menu
Assignee: don → buster
Are you sure that the browser should be handling this?   On Window OS all edit
control automatically have a context menu built into it, it does not need to be
implemented by the application.
Assignee: buster → beppe
I think it's a browser bug.  The editor APP will bring up a context menu in the
editor window.  But the core editor itself doesn't know anything
about UI widgets like context menus.  So the browser will have to somehow be a
mouse listener on the text control and intercept the right mouse
click to bring up a context menu.  Probably the browser will capture ALL right
clicks in the content area.

Having said all that, it's entirely reasonable for the editor team to provide
some sort of xul menu description for a basic editing context menu.  I envision
this as a fragment, meant to be merged in with whatever other menu items the
application wants on the context menu.  That part could be done by
charley, simon, or kathy.  Whoever is looking into context menus in general
for the editor team should work on that part, then assign the bug to browser
(and probably submit another one against mail for text controls in mail compose
window, address book, etc.)
Target Milestone: M14
cahnging to M14 -- post dogfood
Assignee: beppe → sfraser
Target Milestone: M14 → M15
assigning to Simon and setting to past beta
*** Bug 17423 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
spam: could affect my area, so adding self to cc list.
*** Bug 23696 has been marked as a duplicate of this bug. ***
*** Bug 25578 has been marked as a duplicate of this bug. ***
*** Bug 25578 has been marked as a duplicate of this bug. ***
M20
Target Milestone: M15 → M20
Oh, man, that's a complete bummer. I use context menus in edit controls all the
time.
Having talked to hyatt, I should be able to fix this for HTML text inputs. XUL 
inputs are harder. I filed bug 33675 on that case. I'll try doing HTML text input 
context menus for M15.
Depends on: 33675
Target Milestone: M20 → M15
adding akkana, since her fix to bug 27827 might come into conflict with this 
issue.
M16 this puppy
Target Milestone: M15 → M16
Shouldn't the context menus for controls be handled in XBL? That way the all 
controls would maintain a consistant behavior even when modifications to the XBL 
are made. This would also prevent every apps team from having to impliment the 
context menues for controlls themselves. A hack could be accomplished simply by 
using the new XBL methods Hyatt checked in last week, and listining for the 
mouseup handler. Then you could check to see if the right mouse button was 
pressed (not sure how this would effect Mac) and if it was then use JS to show a 
menu (imported from a global XUL file) and call event.preventDefault() to 
prevent further processing of the event. Now I know this is not the most elegant 
solution but it should work as long as my inderstanding of Hyatt's check in is 
correct!
Component: Editor → Embedding: Docshell
*** Bug 27375 has been marked as a duplicate of this bug. ***
Reassign to brade
Assignee: sfraser → brade
Status: ASSIGNED → NEW
Depends on: 37950
Severity: normal → major
Keywords: nsbeta2
Priority: P3 → P1
Whiteboard: nsbeta2
Putting on [nsbeta2+][5/16] radar.  This is a feature MUST complete work by 
05/16 or we may pull this feature for PR2.
Whiteboard: nsbeta2 → [nsbeta2+][5/16]
this cannot be resolved until 37950 is resolved, and that bug has a date set at 
6/1 -- the date for 14874 needs to be past that date.
Moving to [6/01]
Whiteboard: [nsbeta2+][5/16] → [nsbeta2+][6/01]
hoping to work on this bug soon
Status: NEW → ASSIGNED
Changing from [6/01] to [6/15]
Whiteboard: [nsbeta2+][6/01] → [nsbeta2+][6/15]
Blocks: 41554
No longer blocks: 41554
Blocks: 41554
Context Menus now work on edit fields in the browser window.  There were a few 
problems with detecting that we were in an edit field which I have fixed with my 
checkin.  Known issues related to this bug are that commands may not execute due 
to a switch of focus when clicking and debug builds will have 2 asserts before 
the context menu is rendered.  These issues are filed as separate bugs (at last 
the first one is) and are unrelated to this fix.

Short Summary:  I believe this fix is checked in but it is currently blocked by 
several other bugs.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Can't verify since brade indicates it's blocked by other bugs. I will need to be 
notified when these remaining issues are fixed.
Based on the steps included, I'm not able to get a contextual menu to appear when 
focus is in the location bar. Tested on The June 23 build (2000062308) on Mac OS 
9 and Windows 98. If I'm missing a step to verify, let me know.
Chris: the url bar problem has been split off into bug 43936
Based on Kathy's comments, this has been fixed in the June 30th builds.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.