Selection should stop notifying AutoCopyListener of selection changes after unlinked

RESOLVED FIXED in Firefox 63

Status

()

RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({regression})

Trunk
mozilla63
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63 fixed)

Details

Attachments

(1 attachment)

This is a regression of bug 1486370.

Unlink of Selection removes all nsISelectionListener first, then, it removes all its ranges since it does not want to notify the changes anymore.

After bug 1486370, Selection starts to store only bool flag whether it should notify AutoCopyListener of selection changes. So, unless it sets the bool flag to false in Unlink, it'll notify selection change caused by Unlink.
Keywords: regression
This is a regression of bug 1486370.

Unlink of Selection removes all nsISelectionListener first, then, it removes
all its ranges since it does not want to notify the changes anymore.

After bug 1486370, Selection starts to store only bool flag whether it should
notify AutoCopyListener of selection changes. So, unless it sets the bool flag
to false in Unlink, it'll notify selection change caused by Unlink.
Comment on attachment 9005246 [details]
Bug 1487402 - Selection should stop notifying AutoCopyListener of selection changes after unlinked

Olli Pettay [:smaug] has approved the revision.
Attachment #9005246 - Flags: review+

Comment 4

7 months ago
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/2fe5a97dd750
Selection should stop notifying AutoCopyListener of selection changes after unlinked r=smaug

Updated

7 months ago
status-firefox61: --- → unaffected
status-firefox62: --- → unaffected

Comment 6

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2fe5a97dd750
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
status-firefox63: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
status-firefox-esr52: --- → unaffected
status-firefox-esr60: --- → unaffected
You need to log in before you can comment on or make changes to this bug.