Closed Bug 1487453 Opened 3 years ago Closed 3 years ago

Content blocking checkboxes can't be toggled by clicking their label

Categories

(Firefox :: Preferences, defect, P1)

63 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1487048
Tracking Status
firefox62 --- unaffected
firefox63 - affected

People

(Reporter: dao, Unassigned)

References

Details

(Keywords: access)

Clicking a checkbox's label is supposed to toggle the checkbox.
Blocks: 1487455
Keywords: access
Ah, I was about to block this on bug 1486487, but I now realize that XUL checkboxes have a src attribute which we could use in this case.

https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XUL/Attribute/checkbox.src

I agree that we might want to use that to fix this. That would probably also fix bug 1487455...
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Not sure why that resolved it...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
I have a patch for this in bug 1486487.
Status: NEW → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1486487
I suspect bug 1486487 would only partially fix this. Presumably it wouldn't take care of the hover feedback that indicates that clicking the label would toggle the checkbox.
Status: RESOLVED → REOPENED
Depends on: 1486487
Resolution: DUPLICATE → ---
It won't add any hover effects, that's right.
Ehsan, are you intending to fix this after fixing bug 1486487?

(Tracking as this would be a regression in a feature shipping with 63)
Flags: needinfo?(ehsan)
Priority: -- → P1
No, I believe this is a dupe of bug 1487048 and will be fixed by the patch attached there.  Not marking a dupe to give Dao a chance to agree or disagree.

(I do not plan to submit a patch here for now.)
Depends on: 1487048
No longer depends on: 1486487
Flags: needinfo?(ehsan)
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1487048
You need to log in before you can comment on or make changes to this bug.