Closed Bug 1487493 Opened 2 years ago Closed 1 year ago

Enable pref for CSS Containment (layout.css.contain.enabled)

Categories

(Core :: CSS Parsing and Computation, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox63 --- wontfix
firefox69 + fixed
firefox70 --- fixed

People

(Reporter: dholbert, Assigned: dholbert)

References

(Depends on 1 open bug)

Details

(Keywords: dev-doc-complete, Whiteboard: [layout:backlog:2019q2:68])

Attachments

(1 file)

Filing this bug on turning on CSS Containment pref when it's ready.

(i.e. setting layout.css.contain.enabled = true)

(For now I'm assuming we'll let it ride the trains once we pref it on.  But if we want to give it a separate nightly-only bake time & enable it for release versions later on, we can file a separate bug for that second part down the line.)
In any case, this need to be documented on https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Experimental_features#contain-property.

When it ships, the support info on https://developer.mozilla.org/en-US/docs/Web/CSS/contain needs to be updated.

Sebastian
Keywords: dev-doc-needed
Whiteboard: [layout:backlog:2019q2]
Assignee: nobody → dholbert
Whiteboard: [layout:backlog:2019q2] → [layout:backlog:2019q2:68]

Is it still the plan to ship this in 69 as mentioned in Intent to ship?

I think so. As far as I'm aware, bug 1476127 and bug 1555757 are the only bugs that block shipping at this point.

In the next week or two, I plan to post patches for those and then a patch here to remove the EARLY_BETA_OR_EARLIER restriction.

Once this lands on Nightly, I'll request uplift to merge it to Beta [version 69 as of today-ish, since this is merge week]. Should be a safe/trivial uplift, since it's just removing a guard that would only take effect later in the beta cycle anyway.

Status: NEW → ASSIGNED
Pushed by dholbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/58154cdbf898
Remove early-beta restriction on CSS Containment (i.e. let it ride the trains to release). r=TYLin

Comment on attachment 9076614 [details]
Bug 1487493: Remove early-beta restriction on CSS Containment (i.e. let it ride the trains to release). r=TYLin

Beta/Release Uplift Approval Request

  • User impact if declined: CSS Containment feature won't be enabled yet. (Which means sites that use it may not have the correct layout, and some new CSS Containment optimizations won't be applied.)
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This feature is already preffed on through early-beta, and this patch is simply removing the early-beta restriction so that it can proceed past that and be released as part of Firefox 69, since we've fixed all known blocker-level bugs in the feature.
  • String changes made/needed: None
Attachment #9076614 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Comment on attachment 9076614 [details]
Bug 1487493: Remove early-beta restriction on CSS Containment (i.e. let it ride the trains to release). r=TYLin

Removes the early Beta guard on CSS Containment so it can ride the 69 train as called out in the Intent to Ship. Approved for 69.0b4.

Attachment #9076614 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1

(In reply to Sebastian Zartner [:sebo] from comment #1)

In any case, this need to be documented on
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Experimental_features#contain-property

I changed this from "This feature is shipping in Firefox 70" to Firefox 69

(In reply to Sebastian Zartner [:sebo] from comment #13)

I have added it to the release notes for Firefox 69 and created a PR to update the browser compatibility info.

Sebastian

Thanks for doing this Sebastian!

Rachel just updated the property page with an example, and added a landing page for containment:

Can we get a review of these please dholbert? Best place to write review comments is probably https://github.com/mdn/sprints/issues/2106

Flags: needinfo?(dholbert)

I've just posted some nits on the MDN content to Chris and Rachel in slack. (I didn't notice the github link until I'd finished posting all of my feedback comments in slack, sorry) :)

Thanks for the docwriting!

Flags: needinfo?(dholbert)
You need to log in before you can comment on or make changes to this bug.