Closed Bug 1487556 Opened Last year Closed Last year

Disable the Cookies and Site Data section if Content Blocking has been turned off

Categories

(Firefox :: Preferences, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox63 --- fixed

People

(Reporter: ehsan, Assigned: ehsan)

References

Details

Attachments

(2 files, 2 obsolete files)

Right now a couple of our third-party cookie blocking prefs depend on the content blocking pref.  As such, we are planning to modify the Preferences UI to disable Cookies and Site Data UI when Content Blocking has been turned off to remind users of this.

The string to be used here is:

"Your settings in Content Blocking are preventing changes to Cookies and Site Data settings."

The UX mock-up is coming up soon.
Is this still for 63?
Status: NEW → ASSIGNED
Priority: -- → P1
I think so, yes.
Attached patch Part 1: Add the required string (obsolete) — Splinter Review
Attachment #9005601 - Flags: review?(francesco.lodolo)
Keywords: leave-open
Comment on attachment 9005601 [details] [diff] [review]
Part 1: Add the required string

Review of attachment 9005601 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/locales/en-US/browser/preferences/preferences.ftl
@@ +788,5 @@
>  
> +# This is a warning message shown next to a yellow warning icon when the Cookies and Site Data subsection
> +# in Preferences has been disabled due to Content Blocking being disabled.  It is displayed next to the
> +# Cookies and Site Data section.
> +# Note that this string hasn't yet landed in the product (see bug 1487556 for the progress on that.)

As explained in bug 1480900, I would avoid putting this kind of information in comments. 

At some point it will be enabled, and the comment will become obsolete, unless you plan to track them down and update them.

uber-nit: I'd avoid the double space after punctuation
Attachment #9005601 - Flags: review?(francesco.lodolo) → review+
Attached patch Part 1: Add the required string (obsolete) — Splinter Review
Attachment #9005603 - Flags: review?(francesco.lodolo)
Attachment #9005601 - Attachment is obsolete: true
Sure, thanks!
Attachment #9005603 - Attachment is obsolete: true
Attachment #9005603 - Flags: review?(francesco.lodolo)
Attached image Screenshot
Comment on attachment 9006395 [details]
Bug 1487556 - Disable the Cookies and Site Data section if Content Blocking has been turned off; r=johannh

Johann Hofmann [:johannh] has approved the revision.
Attachment #9006395 - Flags: review+
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/14d56f95b51f
Disable the Cookies and Site Data section if Content Blocking has been turned off; r=johannh
Comment on attachment 9006395 [details]
Bug 1487556 - Disable the Cookies and Site Data section if Content Blocking has been turned off; r=johannh

Approval Request Comment
[Feature/Bug causing the regression]: Not a regression, enhancement to a new feature
[User impact if declined]: UI will be left in a confusing state
[Is this code covered by automated tests?]: Yes.
[Has the fix been verified in Nightly?]: Just landed.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No, the code is trivial and disabled by default.
[Why is the change risky/not risky?]: ^
[String changes made/needed]: They have landed as part 1 which is already on 63 beta.
Attachment #9006395 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Comment on attachment 9006395 [details]
Bug 1487556 - Disable the Cookies and Site Data section if Content Blocking has been turned off; r=johannh

Uplift approved for 63 beta 5
Attachment #9006395 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.