Closed Bug 1487915 Opened 3 years ago Closed 3 years ago

Incorrect drawing (and bad performance) on https://www.netlify.com/docs/

Categories

(Core :: Graphics: WebRender, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1488713
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- disabled

People

(Reporter: mstange, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: regression)

Steps to reproduce:
 1. Go to https://www.netlify.com/docs/

Expected results:
There should be a smooth wavy color thingy at the top.

Actual results:
The smooth wavy color thingy is all spliced up into multiple boxes.

It's also very slow to draw.
good = good
bad = long good stripes, but cut off on both ends. First noticeable on the left. Flickers sometimes when scrolling up.
mozregression --good 2018-07-15 --bad 2018-08-24 --pref gfx.webrender.all:true -a https://www.netlify.com/docs/
> 15:47.14 INFO: Last good revision: 010c8880c277c04fb99b5f6d135c99f36e6c3734
> 15:47.14 INFO: First bad revision: b8573b6390b17ece22ce1256cad57dd575834f7d
> 15:47.14 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=010c8880c277c04fb99b5f6d135c99f36e6c3734&tochange=b8573b6390b17ece22ce1256cad57dd575834f7d

> b8573b6390b1	Jeff Muizelaar — Bug 1485691. Re-generate FFI header
> 9ffc581e5e17	Jeff Muizelaar — Bug 1485691. Remark 1081185-1.html as failing.
> 4a57ba156ecf	Jeff Muizelaar — Bug 1485691. Update webrender to commit 93997662842b6d8bafbdb3dde79009c930db66ca

https://github.com/servo/webrender/compare/e70bae07664def86aefd11c86dac818ab7ea64ea...93997662842b6d8bafbdb3dde79009c930db66ca


bad = above bad
good = good, but flickers white at the top when scrolling down, and white at the bottom when scrolling up.
       (https://github.com/servo/webrender/issues/2987 also had such a behavior.)
mozregression --find-fix --bad 2018-08-25 --good 2018-08-28 --pref gfx.webrender.all:true -a https://www.netlify.com/docs/
> 6:03.36 INFO: First good revision: 9b2aa473b2a807dfd412889ebc31aa62dac67339
> 6:03.36 INFO: Last bad revision: c09a146819d3a65127cee966b326efa9ee8ea4aa
> 6:03.36 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c09a146819d3a65127cee966b326efa9ee8ea4aa&tochange=9b2aa473b2a807dfd412889ebc31aa62dac67339

> 9b2aa473b2a8	Jeff Muizelaar — Bug 1485791. Add fuzz to border-radius/clipping-4-canvas.html
> 5cfe12075897	Jeff Muizelaar — Bug 1485791. Update webrender to commit 816ff14c1805c145ccd60d0227d82b1541fc24eb

https://github.com/servo/webrender/compare/93997662842b6d8bafbdb3dde79009c930db66ca...816ff14c1805c145ccd60d0227d82b1541fc24eb


good = above good
bad = comment 0
mozregression --good 2018-08-27 --bad 2018-08-31 --pref gfx.webrender.all:true -a https://www.netlify.com/docs/
> 7:00.84 INFO: Last good revision: 43b1ea339d12e26266d7946b74eb0a7304157aa6
> 7:00.84 INFO: First bad revision: 82efdb13962c299f4501c9f4ee3a4608a4fef85a
> 7:00.85 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=43b1ea339d12e26266d7946b74eb0a7304157aa6&tochange=82efdb13962c299f4501c9f4ee3a4608a4fef85a

> 82efdb13962c	Jeff Muizelaar — Bug 1487429. Update tests for WebRender changes.
> 595a9385a0b0	Jeff Muizelaar — Bug 1487429. Update webrender to 69dae1fe743bf3656d532672366e7193b041b6f7

https://github.com/servo/webrender/compare/5fa5c46e167ca834d8fec3bf662bf420418698f4...69dae1fe743bf3656d532672366e7193b041b6f7
Blocks: 1487429
Flags: needinfo?(gwatson)
Keywords: regression
The wavy effect at the top is SVG - so I guess this could be related to blob (invalidation?) code or perhaps something to do with clips / segments.
Flags: needinfo?(gwatson)
The correctness part has been fixed.
Can confirm. I've filed bug 1490033 about the performance and am going to mark this one as a dupe.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1488713
You need to log in before you can comment on or make changes to this bug.