Closed Bug 14881 Opened 21 years ago Closed 21 years ago

Address Book window take 10min+ to open and resources drop rapidly if Personal Address Book has 55 names 2 lists

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect, P3, critical)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: esther, Assigned: hangas)

References

Details

Using 1999092409-M11 netscape build on win98 system with 192 RAM, 32bit Virtual
Memory, launching an address book window with a personal address book of 55
names 2 lists, it never finishes loading.   Note: with yesterday's build this
was OK.  ON Linux I tried to import this address book as an ldif file, but it
never finishes (yesterday it finished).  Mac can't import .ldif files so I
haven't tested on the Mac.

1. Create an address book with at least 55 names, the only field I have filled
in are FN, LN, DN, email address.  To get a populated addresss book in 5.0: I
exported my address book from 4.x to an .ldif file, then imported it into the
5.0 Address Book, then closed 5.0 and renamed the book to abook.nab in the
User50 direcory).
2. Launch Messenger
3. Select Address Book from the Tasks menu list

Result:  Address Book window shell comes up, stays blank at least 1 minute,
Resouce meter drops System:73 to 12, User: 73 to 12, GDI 74 to 67.  After lots
of churning, the resouces pop back up to the 60's.  At this point the address
book directory pane is displayed, the results pane has filled up with cards, but
the scroll bar is enlarged.  Waited 10 more minutes and listened to continual
chruning of the hard drive but the Address Book window never finished.
Something's up.   I will continue testing.

Expected: The address book to finish loading and the card to be in the results
pane and useable.
OS: Windows 98 → All
Hardware: PC → All
Summary: [PP]Address Book window take 10min+ to open and resources drop rapidly if Personal Address Book has 55 names 2 lists → Address Book window take 10min+ to open and resources drop rapidly if Personal Address Book has 55 names 2 lists
Changing platform to all since linux is having somewhat the same trouble.
Blocks: 9161
Status: NEW → ASSIGNED
Depends on: 13993
On my NT machine using today's debug build, the address book(about 50+
entries)shows up with the scroll bar.  Once I click on the scroll bar, it
crashes.  I was getting the same problem as Esther reported earlier,  but now it
seems went away and back with the scroll bar problem.  The stack trace I got is
the same as bug 13993.
Mark this bug depend on 13993 and when 13993 is fixed, we should verify this
bug.
More information:  with yesterday's build I ran into this several times.  I
narrowed it down that this happens if I haven't opened any of my mail accounts
before opening the Address Book.  I can reproduce this over and over, each time
the border of the Address Book window is up front with the 3-pane mail window
showing through it.  The System and User resources drop to about 12% within 2
minutes and eventually I end up with a system message that 90% of my resources
are taken, I need to close something.   I bring up the system task list and end
the Address book, apprunner closes, resources are freed up.  Maybe I can show
you how to get this to happen on your system.  Let me know.
Using 1999100617M10 commercial build on win98 and 1999100615M10 commercial build
on mac this is fixed.  Thanks Paul! Waiting for linux to verify for that
platform.
Assignee: chuang → hangas
Status: ASSIGNED → NEW
Target Milestone: M11
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fixed by wrapping results tree in a <div> which eliminates many many frames being
created and destroyed.  Fixed for M10 and M11 builds.
Status: RESOLVED → VERIFIED
Using 19991029 this is fixed on linux too. Verified.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.