crash when scrolling through history address book or Personal Abook

VERIFIED FIXED in M11

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
critical
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Scott MacGregor, Assigned: hangas)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I'm not sure who to assign this one too since mailnews stuff isn't on the stack.
As I try to scroll through my history address book, I crash here:

nsGenericElement::GetParent(nsIContent*& aResult)

because mParent inside this class has already been deleted.

Maybe Candice or Paul can help route this to the right place.

nsGenericElement::GetParent(nsIContent * & 0x00000000) line 723 + 24 bytes
AnonymousElement::GetParent(const AnonymousElement * const 0x0447b25c,
nsIContent * & 0x00000000) line 73 + 18 bytes
nsCSSFrameConstructor::FindPrimaryFrameFor(nsCSSFrameConstructor * const
0x040c69d0, nsIPresContext * 0x040c6f00, nsIFrameManager * 0x040c64f0,
nsIContent * 0x0447b25c, nsIFrame * * 0x0012f914) line 7492
StyleSetImpl::FindPrimaryFrameFor(StyleSetImpl * const 0x040c6a70,
nsIPresContext * 0x040c6f00, nsIFrameManager * 0x040c64f0, nsIContent *
0x0447b25c, nsIFrame * * 0x0012f914) line 966
FrameManager::GetPrimaryFrameFor(FrameManager * const 0x040c64f0, nsIContent *
0x0447b25c, nsIFrame * * 0x0012f914) line 239
nsCSSFrameConstructor::FindPrimaryFrameFor(nsCSSFrameConstructor * const
0x040c69d0, nsIPresContext * 0x040c6f00, nsIFrameManager * 0x040c64f0,
nsIContent * 0x0447df8c, nsIFrame * * 0x040c691c) line 7494
StyleSetImpl::FindPrimaryFrameFor(StyleSetImpl * const 0x040c6a70,
nsIPresContext * 0x040c6f00, nsIFrameManager * 0x040c64f0, nsIContent *
0x0447df8c, nsIFrame * * 0x040c691c) line 966
FrameManager::GetPrimaryFrameFor(FrameManager * const 0x040c64f0, nsIContent *
0x0447df8c, nsIFrame * * 0x040c691c) line 239
PresShell::GetPrimaryFrameFor(const PresShell * const 0x040c68c0, nsIContent *
0x0447df8c, nsIFrame * * 0x040c691c) line 1810 + 32 bytes
P
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

19 years ago
Severity: normal → major
QA Contact: lchiang → esther

Updated

19 years ago
Blocks: 11091

Comment 1

19 years ago
*** Bug 12979 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
*** Bug 12979 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
From the stack trace, it looks like the window (or frame) parenting is wrong.
(Assignee)

Updated

19 years ago
Target Milestone: M11 → M12

Updated

19 years ago
OS: Windows NT → All
Hardware: PC → All

Comment 4

19 years ago
This is also a problem in Persoanl Address book as logged in duplicate bug
12979.  This is still a bug on all platforms using 19990922 builds.  Changing
to All platforms.  I will verify the duplicate bug.

Updated

19 years ago
Blocks: 14881

Comment 5

19 years ago
Note: This is causing problems with testing the address book, as the Collected
Addresses (history) address book fills up quite fast requiring the scroll bar
and in some cases crashes just selecting the book.

Updated

19 years ago
Summary: crash when scrolling through history address book → crash when scrolling through history address book or Personal Abook

Comment 6

19 years ago
Using  19991003 on win98 and 19991001 on linux, this is getting worse, just open
an address book (either Personal or History)
that requires a scroll bar and resize the book downward, then Close.  Crash  The
duplicate bug was targeted to be fixed for M11, this one should be bumped up
too.  Added "or Personal Abook" to Summary

Updated

19 years ago
Severity: major → critical

Comment 7

19 years ago
Paul - can you retarget to an earlier milestone?  Hard for Esther to test.
(Assignee)

Updated

19 years ago
Target Milestone: M12 → M11
(Assignee)

Comment 8

19 years ago
Moving to M11, try to fix asap.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

19 years ago
Added <html:div> around the trees, scottip reminded me of this today as a 'fix'
to the problem.  Fix checked in for M11 branch.  This bug was really the same as
13443.
(Reporter)

Comment 10

19 years ago
If the fix is really straightforward, is this something we should consider
checking into the M10 branch too?

Comment 11

19 years ago
Using 1999100617M10 commercial build on win98 and 1999100615M10 commercial build
on mac this is fixed.  Thanks Paul! Waiting for linux to verify for that
platform.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 12

19 years ago
Using 1999100609m11 on win98, 1999100714m11 on linux, 1999100713M11 on mac this
is fixed.  Verified.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.