Closed Bug 1488134 Opened 2 years ago Closed 2 years ago

59.42% sccache requests_not_cacheable (linux64) regression on push 3fde5ca866c7 (Fri Aug 31 2018)

Categories

(Firefox Build System :: General, defect)

Unspecified
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: igoldan, Unassigned)

References

Details

(Keywords: regression)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=07abec90d85cb065f17ddb8f75adcc24be5f5f1f&tochange=3fde5ca866c7a6bc71b06fde4ddacf4137823422

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 59%  sccache requests_not_cacheable linux64 lto debug taskcluster-m4.4xlarge     57.08 -> 91.00


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=15578

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
Product: Testing → Firefox Build System
Flags: needinfo?(mh+mozilla)
This is similar to bug 1487322. This enabled the clang plugin on more build jobs.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mh+mozilla)
Resolution: --- → WONTFIX
I see the static constructors on mozilla-beta now:
== Change summary for alert #15663 (as of Mon, 03 Sep 2018 20:13:51 GMT) ==

Regressions:

 53%  compiler_metrics num_static_constructors linux64 lto debug     136.25 -> 208.00

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=15663
(In reply to Joel Maher ( :jmaher ) (UTC-4) from comment #2)
> I see the static constructors on mozilla-beta now:
> == Change summary for alert #15663 (as of Mon, 03 Sep 2018 20:13:51 GMT) ==
> 
> Regressions:
> 
>  53%  compiler_metrics num_static_constructors linux64 lto debug     136.25
> -> 208.00
> 
> For up to date results, see:
> https://treeherder.mozilla.org/perf.html#/alerts?id=15663

What does this have to do with this bug about sccache requests_not_cacheable ?
this regression was seen on inbound/autoland and then merged to beta, it was labeled as related to this bug, maybe it isn't related- :glandium, should I file a new bug to look at the num-static-constructors?
Flags: needinfo?(mh+mozilla)
It wasn't mentioned in this bug at all, so yes, please file a separate bug. I suspect the root cause is the same as bug 1487622 (as in clang plugin having codegen side effects).
Flags: needinfo?(mh+mozilla)
(In reply to Mike Hommey [:glandium] from comment #5)
> I suspect the root cause is the same as bug 1487622 (as in clang plugin
> having codegen side effects).

I've now confirmed it to be the case. An LTO debug build with my WIP patch for bug 1487622 has 138 static constructors.
oh, so it is something else, thanks for checking.
hmm, looking in detail it is clearly bug 1487330 which is what this bug/regression is related to.
You need to log in before you can comment on or make changes to this bug.