Closed Bug 1488271 Opened 6 years ago Closed 6 years ago

Crash in webrender::prim_store::SpaceMapper<T>::map<T>

Categories

(Core :: Graphics: WebRender, defect, P3)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- disabled
firefox64 --- affected

People

(Reporter: calixte, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-bcc05807-00f9-4960-bf66-76a230180903.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll static void std::panicking::rust_panic_with_hook src/libstd/panicking.rs:521
1 xul.dll static void std::panicking::continue_panic_fmt src/libstd/panicking.rs:426
2 xul.dll static void std::panicking::rust_begin_panic src/libstd/panicking.rs:337
3 xul.dll static void core::panicking::panic_fmt src/libcore/panicking.rs:92
4 xul.dll static void core::panicking::panic src/libcore/panicking.rs:53
5 xul.dll static union core::option::Option<euclid::rect::TypedRect<f32, webrender_api::units::PicturePixel>> webrender::prim_store::SpaceMapper<webrender_api::units::LayoutPixel, webrender_api::units::PicturePixel>::map<webrender_api::units::LayoutPixel, webrender_api::units::PicturePixel> gfx/webrender/src/prim_store.rs:178
6 xul.dll static union core::option::Option<webrender::clip::ClipChainInstance> webrender::clip::ClipStore::build_clip_chain_instance gfx/webrender/src/clip.rs:516
7 xul.dll static void webrender::prim_store::PrimitiveStore::prepare_prim_runs gfx/webrender/src/prim_store.rs:1867
8 xul.dll static void webrender::prim_store::PrimitiveStore::prepare_prim_runs gfx/webrender/src/prim_store.rs:1867
9 xul.dll static void webrender::prim_store::PrimitiveStore::prepare_prim_runs gfx/webrender/src/prim_store.rs:1867

=============================================================

There is 1 crash in nightly 63 with buildid 20180902220539. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1487429.

[1] https://hg.mozilla.org/mozilla-central/rev?node=595a9385a0b0
Flags: needinfo?(jmuizelaar)
Blocks: wr-stability
("infrequent: stage-wr-next P3")

(In reply to Calixte Denizet (:calixte) from comment #0)
> the regression may have been introduced by patch [1] to fix bug 1487429.

= https://github.com/servo/webrender/pull/2995
Flags: needinfo?(jmuizelaar) → needinfo?(gwatson)
Priority: -- → P3
This is a bit strange - I don't see anywhere in the referenced code that can panic (it's possible the source code linked in the bug report is at an incorrect revision?).

We'll probably need to try and reproduce this to debug it, which likely depends on the page being visited (it will be related to a specific clip chain and transform hierarchy).

It's possible it may also be resolved by patches that will be landing in the next week or so.
Flags: needinfo?(gwatson)
Closing because no crashes reported for 12 weeks.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
There are still some crashes so reopen it.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Can you link to a crash on a recent buildid? I don't see any.
Flags: needinfo?(cdenizet)
That particular crash is bogus, the stack is garbage. The app notes have WR- which means WebRender is off there.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.