Closed Bug 1488818 Opened 2 years ago Closed 2 years ago

Google Hangouts stopped working in Firefox 63 (soon to be beta)!

Categories

(Core :: WebRTC: Signaling, defect, P2, critical)

63 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1487617

People

(Reporter: jib, Assigned: drno)

References

Details

(Whiteboard: [webcompat])

Unable to join calls.

STR:
 1. In Chrome, go to https://hangouts.google.com/ and create a video room; get URL.
 2. In Firefox, paste in URL. e.g. https://hangouts.google.com/call/W2-dY3imA4tpnJXJ25k6AAEE
 3. Allow camera and mic sharing as necessary.

Expected result:
- Joins room and sees other participant (e.g. self-view flips around y-axis)

Actual result:
- "Error: Sorry, we encountered a problem joining this video call.  Close"

  "The video call ended because of an error"

Web console reveals:

  InvalidSessionDescriptionError: Changing the mid of m-sections is not allowed.
  InvalidStateError: RTCPeerConnection is gone (did you enter Offline mode?)

Regression range:

17:43.20 INFO: Last good revision: 54beb60ca7d5221a1b4bb61019fe0def40949899
17:43.20 INFO: First bad revision: 836086dfcd2fb2017381a4ec5d32f757f8b1458f
17:43.20 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=54beb60ca7d5221a1b4bb61019fe0def40949899&tochange=836086dfcd2fb2017381a4ec5d32f757f8b1458f

Tue Aug 28 21:23:04 2018 +0000	836086dfcd2f	Byron Campen [:bwc] — Bug 1483338: Stop using level as the identifier for media transports. r=mjf
Most likely a web-compat issue, but tracking it in media for now.

With 63 about to become beta, do we want to revert Bug 1483338 to give Google time address fix this?
(In reply to Jan-Ivar Bruaroey [:jib] (needinfo? me) from comment #1)
> Most likely a web-compat issue, but tracking it in media for now.
> 
> With 63 about to become beta, do we want to revert Bug 1483338 to give
> Google time address fix this?

No. There's other stuff I'm working on that's going to be a nightmare to unrot if we back this out from underneath it.
Assignee: docfaraday → drno
Flags: needinfo?(drno)
Whiteboard: [webcompat]
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1487617
Yeah, this is a hangouts bug; they're rewriting the local description's mids.
Clearing tracking/status flags in favor of 1487617.
You need to log in before you can comment on or make changes to this bug.