Closed Bug 1488933 Opened Last year Closed Last year

Link to the new content blocking onboarding from about:privatebrowsing when the CB UI is enabled

Categories

(Firefox :: Private Browsing, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox63 --- fixed
firefox64 --- fixed

People

(Reporter: johannh, Assigned: johannh)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We have a different onboarding for CB and we need to make sure to link to it from about:privatebrowsing.
Comment on attachment 9006716 [details]
Bug 1488933 - Link to the new content blocking onboarding from about:privatebrowsing when the CB UI is enabled. r=Gijs

:Gijs (he/him) has approved the revision.
Attachment #9006716 - Flags: review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e57c8ca8d1b
Link to the new content blocking onboarding from about:privatebrowsing when the CB UI is enabled. r=Gijs
This needs a backport, right?
Comment on attachment 9006716 [details]
Bug 1488933 - Link to the new content blocking onboarding from about:privatebrowsing when the CB UI is enabled. r=Gijs

Approval Request Comment
[Feature/Bug causing the regression]: UI Tour changes in bug 1484585
[User impact if declined]: Users won't get the correct UI Tour for the new Content Blocking feature if they visit it from about:privatebrowsing.
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: Hard to test right now, since the backend is not in place yet. But it's a very simple patch so it shouldn't be necessary.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Very simple patch that only updates a link on about:privatebrowsing
[String changes made/needed]: None
Attachment #9006716 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/4e57c8ca8d1b
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Comment on attachment 9006716 [details]
Bug 1488933 - Link to the new content blocking onboarding from about:privatebrowsing when the CB UI is enabled. r=Gijs

Uplift approved for 63 beta 5
Attachment #9006716 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 1490729
You need to log in before you can comment on or make changes to this bug.