Closed Bug 1489569 Opened Last year Closed Last year

Autofill with LastPass flickers and locks up app

Categories

(GeckoView :: General, defect, P1)

Unspecified
Android
defect

Tracking

(geckoview62 fixed, firefox-esr60 wontfix, firefox62 wontfix, firefox63 fixed, firefox64 verified)

VERIFIED FIXED
mozilla64
Tracking Status
geckoview62 --- fixed
firefox-esr60 --- wontfix
firefox62 --- wontfix
firefox63 --- fixed
firefox64 --- verified

People

(Reporter: ekager, Assigned: jchen)

References

Details

(Whiteboard: [geckoview:klar:p1])

Attachments

(3 files)

Attached image Gif of behavior
STR:
1. Go to facebook.com
2. LastPass tries to autofill

Expected: Autofills
Actual: Locks up screen and back button with keyboard flickering, need to use gestures or home button to exit Focus.

Using LastPass on Pixel 2 and Focus Nightly with GV 62 Rel Branch
Assignee: nobody → nchen
Blocks: 1461961
OS: Unspecified → Android
Priority: -- → P1
To avoid unnecessary setActive calls, only call it when we have a
display and when the display acquires or releases a surface. In other
cases, we can delay the setActive call until later.
When the window temporarily loses focus (e.g. due to auto-fill popups),
don't call setFocus(false). Otherwise, we can end up disrupting user
interaction (e.g. causing the auto-fill popup to flicker). Only call
setFocus(false) when we are reasonably sure the focus loss is not
temporary.
Comment on attachment 9007379 [details]
Bug 1489569 - 1. Avoid unnecessary setActive calls; r?droeh

Dylan Roeh (:droeh) has approved the revision.
Attachment #9007379 - Flags: review+
Comment on attachment 9007380 [details]
Bug 1489569 - 2. Don't blur window on temporary focus loss; r?droeh

Dylan Roeh (:droeh) has approved the revision.
Attachment #9007380 - Flags: review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/48c8c080a960
1. Avoid unnecessary setActive calls; r=droeh
https://hg.mozilla.org/integration/mozilla-inbound/rev/4bc9731f089e
2. Don't blur window on temporary focus loss; r=droeh
https://hg.mozilla.org/mozilla-central/rev/48c8c080a960
https://hg.mozilla.org/mozilla-central/rev/4bc9731f089e
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Comment on attachment 9007379 [details]
Bug 1489569 - 1. Avoid unnecessary setActive calls; r?droeh

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1461961
[User impact if declined]: Screen flickering when auto-fill is enabled, making the app not usable.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Not really
[Why is the change risky/not risky?]: Small patches that only address the bug
[String changes made/needed]: None
Attachment #9007379 - Flags: approval-mozilla-beta?
Comment on attachment 9007379 [details]
Bug 1489569 - 1. Avoid unnecessary setActive calls; r?droeh

[Approval Request Comment]

If this is not a sec:{high,crit} bug, please state case for consideration: Regression fix for a GeckoView blocker.

User impact if declined: Bug makes app unusable when auto-fill is enabled.

Fix Landed on Version: 64

Risk to taking this patch (and alternatives if risky): Very small; patches are small and only address the bug itself.

String or UUID changes made by this patch: None

See https://wiki.mozilla.org/Release_Management/Uplift_rules for more info.
Attachment #9007379 - Flags: approval-mozilla-geckoview62?
Comment on attachment 9007379 [details]
Bug 1489569 - 1. Avoid unnecessary setActive calls; r?droeh

Approved for 63 Beta 6 as this is a regression with a very popular extension. I'd like QE to verify the fix on  beta once it is landed.
Attachment #9007379 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Whiteboard: [geckoview:klar:p1]
Comment on attachment 9007379 [details]
Bug 1489569 - 1. Avoid unnecessary setActive calls; r?droeh

I can't a+ but this LGTM for uplifting to the GV 62 relbranch.
Comment on attachment 9007379 [details]
Bug 1489569 - 1. Avoid unnecessary setActive calls; r?droeh

On behalf of Chris :)
Attachment #9007379 - Flags: approval-mozilla-geckoview62? → approval-mozilla-geckoview62+
(In reply to Pascal Chevrel:pascalc from comment #9)
> 
> Approved for 63 Beta 6 as this is a regression with a very popular
> extension. I'd like QE to verify the fix on  beta once it is landed.

We tested on Firefox Focus build 7.0.12 with LastPass following the steps from the description and we were able to log in. For Fennec 63, we can't test due to bug 1485810 where status-firefox63: is wontfix. But on Fennec Nightly the 1Password is working on Motorola Nexus 6(Android 7.1.1) and Google Pixel(Android 9).
  Due to whiteboard [geckoview:klar:p1] and comment 9 I just want to make sure that we are on the same page, so my question is we wait till the fix from bug 1485810 is landed in Beta? Right now LastPass is not working on Beta 63.
Thanks!
Flags: needinfo?(pascalc)
(In reply to Sorina Florean [:sorina] from comment #14)
> We tested on Firefox Focus build 7.0.12 with LastPass following the steps
> from the description and we were able to log in. For Fennec 63, we can't
> test due to bug 1485810 where status-firefox63: is wontfix. But on Fennec
> Nightly the 1Password is working on Motorola Nexus 6(Android 7.1.1) and
> Google Pixel(Android 9).
>   Due to whiteboard [geckoview:klar:p1] and comment 9 I just want to make
> sure that we are on the same page, so my question is we wait till the fix
> from bug 1485810 is landed in Beta? Right now LastPass is not working on
> Beta 63.

I think bug 1485810 is Fennec-specific. Since it's marked status-firefox63=wontfix, then we can't test until Fennec 64 Beta.

Did LastPass work in Fennec 62?
(In reply to Chris Peterson [:cpeterson] from comment #15)
> (In reply to Sorina Florean [:sorina] from comment #14)
> > We tested on Firefox Focus build 7.0.12 with LastPass following the steps
> > from the description and we were able to log in. For Fennec 63, we can't
> > test due to bug 1485810 where status-firefox63: is wontfix. But on Fennec
> > Nightly the 1Password is working on Motorola Nexus 6(Android 7.1.1) and
> > Google Pixel(Android 9).
> >   Due to whiteboard [geckoview:klar:p1] and comment 9 I just want to make
> > sure that we are on the same page, so my question is we wait till the fix
> > from bug 1485810 is landed in Beta? Right now LastPass is not working on
> > Beta 63.
> 
> I think bug 1485810 is Fennec-specific. Since it's marked
> status-firefox63=wontfix, then we can't test until Fennec 64 Beta.
> 
> Did LastPass work in Fennec 62?

No, we tested on Fennec 62.0.3 and LastPass or 1PAssword are not working.
Device:
 - Google Pixel C (Android 8.0.0)

Verified as fixed in the latest Beta build 64b.0b6 (2018-11-01) but note that I was able to test this issue only with 1Password, the LastPass app didn't worked.
I submitted an issue for LastPass not working for Fennec that can be found here 1504257.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1504257
Product: Firefox for Android → GeckoView
Target Milestone: Firefox 64 → mozilla64
Flags: needinfo?(pascalc)
You need to log in before you can comment on or make changes to this bug.