Language Pack (de) messes with search engine preferences

RESOLVED DUPLICATE of bug 1489820

Status

()

defect
RESOLVED DUPLICATE of bug 1489820
7 months ago
7 months ago

People

(Reporter: gerhard.grossmann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180905221508

Steps to reproduce:

I had some problems with the search engine preferences.

1: On https://de.wikipedia.org the OpenSearch could not be added. There was no green plus icon above the magnifier symbol in the search field. At Wikipedia pages of other languages the OpenSearch plus icon for One Click Search Enginges was visible.

2: With some tricks I got Wikipedia (de) as a Search Engine and gave it the keyword “wp” in the preferences. This keywords also was gone after a restart of the browser.

3: In the preferences I deleted the search engines Amazon, Ecosia, and some more from the list. After restarting the browser they were back again (if I just deactivated them by removing the blue check mark they stayed deactivated).

To search for the cause I deactivated all add-ons and tried – without success. Then I deactivated only the Deutsch (DE) Language Pack which I had installed via the official page https://addons.mozilla.org/de/firefox/addon/deutsch-de-language-pack/ …


Actual results:

… and all three bugs I had with the search preferences were gone. Even the German Wikipedia page now show the plus icon to add it as a One Click Search Engine.


Expected results:

I’d expect that my search engine preferences won’t be reset when I’d like to have my browser UI in German.
(Reporter)

Comment 1

7 months ago
PS: Of course the Search Wikipedia (de) was not present first, but only Wikipedia (en) [which I deleted]. When a search engine is already installed, the green plus does not appear. Maybe the language pack brings some search engine with it but does not correctly update the search engine list in the preferences?
(In reply to Gerhard Großmann from comment #0)
> 1: On https://de.wikipedia.org the OpenSearch could not be added. There was
> no green plus icon above the magnifier symbol in the search field. At
> Wikipedia pages of other languages the OpenSearch plus icon for One Click
> Search Enginges was visible.
Did a move of the mouse over the available search engines in the searchbox (mouse over magnifier glass > dropdown) show "Wikipedia (de)", "Wikipedia (en)" or anything else?

> 2: With some tricks I got Wikipedia (de) as a Search Engine and gave it the
> keyword “wp” in the preferences. This keywords also was gone after a restart
> of the browser.
> 
> 3: In the preferences I deleted the search engines Amazon, Ecosia, and some
> more from the list. After restarting the browser they were back again (if I
> just deactivated them by removing the blue check mark they stayed
> deactivated).
There are search engine regressions being worked on in bug 1305705. Needinfoing the developer mkaply to check on these here.

Did you have manually added search engines while Firefox was in English which are come with the German language pack by default? The custom one gets disabled and the one from the language pack activated and the search keyword gets lost due to that (as far as I know).
Component: de / German → Search
Flags: needinfo?(mozilla)
Product: Mozilla Localizations → Firefox
(Reporter)

Comment 3

7 months ago
(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #2)
> Did a move of the mouse over the available search engines in the searchbox
> (mouse over magnifier glass > dropdown) show "Wikipedia (de)", "Wikipedia
> (en)" or anything else?
There wasn’t any Wikipedia variant shown in the pop-up. Visiting en.wikipedia.org gave me the possibility to add their search engine via the green plus.

After restarting the browser a formally deleted Wikipedia (de) is back in the list (always without keyword [again]). After deleting it and visiting the German Wikipedia page there’s still no plus icon (but also no Wikipedia in the pop-up)

> Did you have manually added search engines while Firefox was in English
> which are come with the German language pack by default? The custom one gets
> disabled and the one from the language pack activated and the search keyword
> gets lost due to that (as far as I know).
As far as I remember I only installed search engines while the language pack was present. I’ve installed the Leo Deu-Eng V2.0 from https://www.leo.org. Preinstalled (with German Language Pack) was another version, Leo Eng-Deu, which comes haunting back but does not interfere or reset the keyword “leo”of my custom version V2.0.

When I deactivate the language pack and restart my browser in English then there’s an additional Twitter search, Amazon.com and Wikipedia (en), but no Wikipedia (de) – so it should not be already installed in the “English mode”.

Sorry that my description may seem a little bit confused. I try to describe the behavior as sorted as possible.
(Reporter)

Comment 4

7 months ago
Maybe another thing to consider: On my system (Ubuntu 16.04) Firefox is installed via the package manager. There you install the basic package (English Firefox) plus a firefox-locale-de package. At least since Firefox 62 this localization package no longer works [correctly?]. Earlier it enabled a) the correct language for the UI and b) access to the spellchecker dictionaries which were installed with the system.

To see what happens I removed my German localization in the package manager (and installed Swedish as a test). Result: The UI still was in German, the German dictionary stayed present (I had reinstalled/updated them within Firefox after the 62 update). Swedish language was present in the languages list but had no effect on the UI, dictionaries or search engines (after restarting with deactivated German language Firefox became English instead of Swedish). So I deduced that this localization packages from the package manager no longer work. I kept the German package uninstalled, hoping for eliminating this bug – but it seems to be independent of it.

Updated

7 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Flags: needinfo?(mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1489820
You need to log in before you can comment on or make changes to this bug.