Closed Bug 1490035 Opened 3 years ago Closed 2 years ago

Re-implement Places Autocomplete results timing telemetry

Categories

(Firefox :: Address Bar, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1515081
Tracking Status
firefox64 --- affected

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Whiteboard: [fxsearch])

There are two telemetry timing measurements that we need to reimplement with the new UrlbarController:

PLACES_AUTOCOMPLETE_1ST_RESULT_TIME_MS
PLACES_AUTOCOMPLETE_6_FIRST_RESULTS_TIME_MS

We also need to check where these are currently logged in UnifiedComplete and understand how the new implementation may affect the general results timing if at all.
Whiteboard: [fxsearch]
After some discussions with Marco on irc:

PLACES_AUTOCOMPLETE_6_FIRST_RESULTS_TIME_MS is potentially out of date now, as we show 10 results at once. It may also make more sense to invert it, e.g. "how many results could we provide in n milliseconds?". Maybe base that around the current 6 results peak of 62 - 69ms.

The intent here is that we're measuring "time to provide enough choice to the user" and then, that we're not regressing it.
Sigh, just realised I'd duped myself yesterday. Will dupe forward as that's a clearer bug for what we're doing, and comment 1 will be covered in a separate bug.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1515081
You need to log in before you can comment on or make changes to this bug.