Re-implement autocomplete 1st/6 entries timing telemetry for on the new QuantumBar

RESOLVED FIXED in Firefox 66

Status

()

P1
normal
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

unspecified
Firefox 66
Points:
---

Firefox Tracking Flags

(firefox66 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(2 attachments)

(Assignee)

Description

3 months ago
As part of the work for the new QuantumBar, we should ensure that the telemetry probes PLACES_AUTOCOMPLETE_1ST_RESULT_TIME_MS and PLACES_AUTOCOMPLETE_6_FIRST_RESULTS_TIME_MS continue working.

These are probes for the amount of time it takes to get the first result, and then the amount of time for the first six results.
(Assignee)

Updated

3 months ago
Summary: Re-implement telemetry for Autocomplete 1st/6 entries on the new QuantumBar → Re-implement autocomplete 1st/6 entries timing telemetry for on the new QuantumBar
(Assignee)

Updated

3 months ago
Duplicate of this bug: 1490035
(Assignee)

Updated

3 months ago
Assignee: nobody → standard8
Status: NEW → ASSIGNED
Priority: P2 → P1
(Assignee)

Comment 2

3 months ago
Note: for now, I've gone for these being defined in the controller. As we add more, we can decide if it makes sense for a separate module or not.
(Assignee)

Comment 3

3 months ago
Currently, it only passes that test due to awaiting for a non-promise.

Comment 5

3 months ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5747fe4edb8a
Fix the cancel search test for the UrlbarController to actually test the cancel. r=mak
https://hg.mozilla.org/integration/autoland/rev/068f7beef2c8
Reimplement autocomplete result timing telemetry for the new quantumbar. r=mak

Comment 6

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
status-firefox66: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.