Version Registry: Registry info is lost after a patch

RESOLVED INVALID

Status

P4
minor
RESOLVED INVALID
19 years ago
3 years ago

People

(Reporter: jimmykenlee, Assigned: cathleennscp)

Tracking

Trunk
Future
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build: 9/24/99 SeaMonkey build

1. From http://jimbob/trigger2.html, click drop-down button and select
   f_addmacpatch_exe and click Trigger case button to set up file for
   patching
2. Checking the Version registry at this time shows that everything is fine
   so far
3. From http://jimbob/trigger2.html, click drop-down button and select
   f_macpatch_exe and click Trigger case button to patch file

var regName = "macpatch_exe";
var vi = new InstallVersion();
var jarSrc = "NCSA Telnet 2.7b5x.gdf";

vi.init("1.2.1.1");
Install.StartInstall("Functional: f_macpatch_exe", "/f_macpatch_exe", vi, 0);
f = Install.GetFolder("Program", "f_macpatch_exe");
err = Install.Patch(regName, vi, jarSrc, f, "SimpleText", true);
Install.LogComment("Install Patch = " + err);

RESULT:
The file is patched successfully.  The Install.log appears correct and accurate.
The Version registry shows the expected absolute pathname "f_macpatch_exe".  But
a dump of this node shows nothing.

EXPECTED RESULT:
A dump of the node shows a leaf "macpatch_exe/SimpleText" complete with
RefCount, Path, and Version.
(Assignee)

Updated

19 years ago
Hardware: PC → Macintosh
(Assignee)

Comment 1

19 years ago
set platform to Mac, looks like Mac specific...
(Assignee)

Updated

19 years ago
Target Milestone: M11
(Assignee)

Comment 2

19 years ago
*** Bug 14996 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Blocks: 16654

Updated

19 years ago
Blocks: 17432

Updated

19 years ago
Blocks: 17907

Updated

19 years ago
Blocks: 18471

Comment 3

19 years ago
cathleen returns for m13

Comment 4

19 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Target Milestone: M13 → M15
Post beta for patching.
(Assignee)

Comment 6

19 years ago
marking as REMIND
bug meeting 3/20
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → REMIND

Updated

19 years ago
No longer blocks: 17432

Updated

19 years ago
No longer blocks: 17907

Updated

19 years ago
No longer blocks: 18471
REMIND is deprecated per bug 35839.
Severity: critical → normal
Status: RESOLVED → REOPENED
Resolution: REMIND → ---
Target Milestone: M15 → ---

Comment 8

16 years ago
3 years later... 

As a non-Netscape-employee, I have no idea what this bug means, but I suspect
that it's no longer relevant. 

Resolved?
Keywords: qawanted
(Reporter)

Comment 9

16 years ago
Patching is a feature that has not been implemented.  At one time it was
considered, and this bug was a result of it partially working.  This bug is only
relevant if the Patching feature is going to be pursued.

Updated

16 years ago
Severity: normal → minor
Keywords: qawanted
OS: Mac System 8.5 → MacOS X
Priority: P3 → P4
Target Milestone: --- → Future
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago10 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.