Closed Bug 1490163 Opened Last year Closed 11 months ago

Sync the Firefox Home Content prefs

Categories

(Firefox :: Sync, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 66
Tracking Status
firefox66 --- fixed

People

(Reporter: Lina, Assigned: Lina)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The Pocket support team got this request: https://twitter.com/tenten8401/status/1038181625811619846

I think that specific pref is `browser.newtabpage.activity-stream.feeds.section.topstories`, but there are other `browser.newtabpage.activity-stream.*` prefs that we should probably sync, too.

Ursula, do you have suggestions for AS prefs to sync, or which ones not to? :-)
Flags: needinfo?(usarracini)
Blocks: syncmore
The list of prefs that affect about:preferences#home is:

browser.newtabpage.activity-stream.showSearch

browser.newtabpage.activity-stream.feeds.topsites
browser.newtabpage.activity-stream.topSitesRows

browser.newtabpage.activity-stream.feeds.snippets

browser.newtabpage.activity-stream.feeds.section.topstories
browser.newtabpage.activity-stream.section.topstories.rows

browser.newtabpage.activity-stream.feeds.section.highlights
browser.newtabpage.activity-stream.section.highlights.includeVisited
browser.newtabpage.activity-stream.section.highlights.includeBookmarks
browser.newtabpage.activity-stream.section.highlights.includeDownloads
browser.newtabpage.activity-stream.section.highlights.includePocket
browser.newtabpage.activity-stream.section.highlights.rows

These should probably all be sync-ed :)
Flags: needinfo?(usarracini)
Assignee: nobody → lina
Priority: -- → P2
Duplicate of this bug: 1513664
Pushed by kcambridge@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71273ff7fc0c
Sync the Firefox Home Content prefs. r=k88hudson
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Duplicate of this bug: 1521720

Just tested the browser.newtabpage.activity-stream.showSearch parameter.
I couldn't have it synced using my Firefox Account between different Firefox installations.

Duplicate of this bug: 1525161
You need to log in before you can comment on or make changes to this bug.