Closed Bug 1490294 Opened Last year Closed Last year

Fix services/sync regression in suite's l10n.toml

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set

Tracking

(seamonkey2.57esr fixed, seamonkey2.60 fixed)

RESOLVED FIXED
Future
Tracking Status
seamonkey2.57esr --- fixed
seamonkey2.60 --- fixed

People

(Reporter: Pike, Assigned: Pike)

References

Details

Attachments

(1 file)

There's a regression from https://hg.mozilla.org/comm-central/diff/ea4c0d8fc22e/suite/locales/l10n.toml that I just stumbled upon in testing something unrelated, it lost the {mozilla}/ in the reference path.

Patch coming up.
Attachment #9008045 - Flags: review?(frgrahl)
Is this still needed? Starting with esr60 the former mozilla dir under comm-central is now the top sourcedir and comm-central goes under it as comm so mozilla no longer needs to be a variable?

I might have acutally missed the other ones in bug 1481067 for suite.
Flags: needinfo?(l10n)
Comment on attachment 9008045 [details] [diff] [review]
adding {mozilla} back

Anyway this is correct. Thanks. It just fell under the radar because right now we have sync disabled. Until we port 1.5 these are not used.
Attachment #9008045 - Flags: review?(frgrahl) → review+
Yes, we still need the {mozilla} for the toolkit strings.

I just looked at tb, and it runs 

/builds/worker/workspace/build/src/mach compare-locales -Dmozilla=.. --merge /builds/worker/workspace/build/src/obj-firefox/comm/mail/locales/merge-dir /builds/worker/workspace/build/src/comm/mail/locales/l10n.toml /builds/worker/workspace/build/l10n fi

See the -Dmozilla=.. . 

If the mozilla subdir isn't supported anymore, we should make the default `..`. I'll still need the define for the l10n dashboard , though.
Flags: needinfo?(l10n)
Pushed by axel@mozilla.com:
https://hg.mozilla.org/comm-central/rev/a2bcfedfe138
fix mozilla reference in suite/locales/l10n.toml, r=frg
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Comment on attachment 9008045 [details] [diff] [review]
adding {mozilla} back

[Approval Request Comment]
Regression caused by (bug #): 1451847
User impact if declined: I won't be able to migrate dashboard automation to toml files this cycle
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: None

I'd like this to also land on comm-beta, so that I can drop the current .ini logic in the dashboard in favor of toml files alone.
Attachment #9008045 - Flags: approval-comm-beta?
Comment on attachment 9008045 [details] [diff] [review]
adding {mozilla} back

Lets take it to esr60 too.
Attachment #9008045 - Flags: approval-comm-esr60?
Ian, Frank, can you get to the approvals here? I'd love to have this out of the way.
Comment on attachment 9008045 [details] [diff] [review]
adding {mozilla} back

a=me
Attachment #9008045 - Flags: approval-comm-esr60?
Attachment #9008045 - Flags: approval-comm-esr60+
Attachment #9008045 - Flags: approval-comm-beta?
Attachment #9008045 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.