Closed Bug 1490353 Opened 3 years ago Closed 3 years ago

Crash in java.lang.IllegalArgumentException: !!! BUG 849589 !!! origUrl=jar:jar:file:/data/app/org.mozilla.firefox_beta-1/base.apk!/assets/omni.ja!/res/multilocale.txt at org.mozilla.gecko.util.GeckoJarReader.getStream(Unknown Source)

Categories

(Firefox for Android Graveyard :: General, defect)

Firefox 63
x86
Android
defect
Not set
critical

Tracking

(firefox63 affected)

RESOLVED WORKSFORME
Tracking Status
firefox63 --- affected

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-825a5777-ba1b-4182-8a5c-431730180911.
=============================================================

This new signature is showing up in 63b3: https://bit.ly/2x6eV2b. It is rather odd that the manufacturer and model seem to be garbage characters.

There are 2 with comments, but unfortunately they are not useful. It looks as if 5 years ago we also had a similar crash: bug 849589.

Top 3 frames of crashing thread:

0 libxul.so GeckoAppShellSupport::ReportJavaCrash widget/android/nsAppShell.cpp:281
1 data@app@org.mozilla.firefox_beta-1@base.apk@classes.dex data@app@org.mozilla.firefox_beta-1@base.apk@classes.dex@0xf839ca 
2 dalvik-non moving space (deleted) dalvik-non moving space @0xb9ff 

=============================================================
According to what was posted in Bug 1490354, this may some automation running and reporting back a manufacturer/model.
So far this has only been seen in 63b3. We can leave open until the beta cycle concludes to see what happens.
Closing this one out as WFM. No crashes seen since the initial filing.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.