Closed Bug 1490611 Opened Last year Closed Last year

Refactor DISPLAY_*_WIDTH macro names(and the relevant struct of the macro contents) to logical DISPLAY_*_INLINE_SIZE

Categories

(Core :: Layout, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: zjz, Assigned: zjz)

References

Details

Attachments

(1 file)

https://searchfox.org/mozilla-central/rev/de7676288a78b70d2b9927c79493adbf294faad5/layout/generic/nsFrame.h#859

The two macros(as well as the struct in the macro content) should go
through a renaming refactoring to reflect the fact that they're actually
referring to a minimum/preferred inline size, not a minimum/preferred width.
Assignee: nobody → zjz
Status: NEW → ASSIGNED
Comment on attachment 9008354 [details]
Bug 1490611 - physical to logical name refactor: DISPLAY_*_WIDTH to DISPLAY_*_INLINE_SIZE(as well as the relevant struct in the macro contents) r?jfkthame

Jonathan Kew (:jfkthame) has approved the revision.
Attachment #9008354 - Flags: review+
Thanks for the review.
Keywords: checkin-needed
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/af0fc623d0b5
physical to logical name refactor: DISPLAY_*_WIDTH to DISPLAY_*_INLINE_SIZE(as well as the relevant struct in the macro contents) r=jfkthame
Keywords: checkin-needed
Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0dd2428ceb74
physical to logical name refactor: DISPLAY_*_WIDTH to DISPLAY_*_INLINE_SIZE(as well as the relevant struct in the macro contents) r=jfkthame
https://hg.mozilla.org/mozilla-central/rev/af0fc623d0b5
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.