Rename a few macro and variables about intrinsic inline-size
Categories
(Core :: Layout, task, P3)
Tracking
()
Tracking | Status | |
---|---|---|
firefox68 | --- | fixed |
People
(Reporter: TYLin, Assigned: TYLin)
References
Details
Attachments
(4 files)
Bug 1490611 added some FIXME to rename NS_INTRINSIC_WIDTH_UNKNOWN and nsBlockFrame::{mMinWidth, mPrefWidth}.
I'll post patches to rename them later.
Assignee | ||
Comment 1•6 years ago
|
||
This patch is generated by running the following script under layout/,
and then manually delete the FIXME comment in LayoutConstants.h
#!/bin/bash
function rename() {
find .
-type f
! -path "./obj*"
! -path "./.git"
! -path "./.hg"
( -name ".cpp" -or
-name ".h" )
-exec sed -i -e "s/$1/$2/g" "{}" ;
}
rename NS_INTRINSIC_WIDTH_UNKNOWN NS_INTRINSIC_ISIZE_UNKNOWN
Assignee | ||
Comment 2•6 years ago
|
||
Instead of renaming it to mMinISize, I choose mCachedMinISize because
both grid and flex container frames use mCachedMinISize for similar
purpose.
Depends on D29746
Assignee | ||
Comment 3•6 years ago
|
||
Like Part 2, I choose mCachedPrefISize because grid and flex container
are using it.
Depends on D29747
Assignee | ||
Comment 4•6 years ago
|
||
Depends on D29748
Comment 6•6 years ago
|
||
bugherder |
https://hg.mozilla.org/mozilla-central/rev/a3ddb4c1ce28
https://hg.mozilla.org/mozilla-central/rev/2a7dcc0cc43d
https://hg.mozilla.org/mozilla-central/rev/5ad9fb7a2713
https://hg.mozilla.org/mozilla-central/rev/00441f7cdd1c
Updated•6 years ago
|
Description
•