Closed Bug 1490664 Opened Last year Closed Last year

[Fennec][MacOS] javac cannot find symbol - code related to crash handling

Categories

(Firefox Build System :: Android Studio and Gradle Integration, enhancement)

63 Branch
enhancement
Not set

Tracking

(firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: petru, Assigned: snorp)

References

Details

Attachments

(1 file)

"./mach build" on MacOS currently fails because of "cannot find symbol" javac errors in  :app:compileOfficialWithoutGeckoBinariesNoMinApiPhotonDebugJavaWithJavac

They all seem to be related to the code for crash handling, code which has been changed recently in bug 1483329.

The interesting part is that local Linux builds are successful for the same codebase and same java version - 1.8.0_181 and there have also been successful try builds like 
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=bf0a33ff3b308f6df447f054f94c41d4441608f6&searchStr=android
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=1169e8a4ca2b7f3cbffdaf70f6d18a5142ed32d7&searchStr=android 

Issue is reproducing on 3 different stations.


First error is
> ..../CrashHandlerService.java:16: error: cannot find symbol
>           intent.setClass(this, CrashReporterActivity.class);
>                                 ^
>           symbol:   class CrashReporterActivity
>           location: class CrashHandlerService`

Then if we are to comment https://searchfox.org/mozilla-central/source/mobile/android/app/build.gradle#128 we get a lot of other errors starting with
> ..../CrashReporterActivity.java:138: error: cannot find symbol
>           setContentView(R.layout.crash_reporter);
>                                  ^
>           symbol:   variable crash_reporter
>           location: class layout
> ..../CrashReporterActivity.java:206: error: cannot find symbol
>           final CheckBox allowContactCheckBox = (CheckBox) findViewById(R.id.allow_contact);
>                                                                             ^
>           symbol:   variable allow_contact
>           location: class id
> ..../CrashReporterActivity.java:206: warning: [cast] redundant cast to <any>
>           final CheckBox allowContactCheckBox = (CheckBox) findViewById(R.id.allow_contact);
>                                                 ^
Blocks: 1483993
This issue seems to have appeared after recent work regarding the crash handling API, tracked in bug 1483329
Flags: needinfo?(snorp)
Yeah, looks like I broke --disable-crashreporter, which is always used when building on Mac.
Assignee: nobody → snorp
Flags: needinfo?(snorp)
Comment on attachment 9008498 [details]
Bug 1490664 - Fix Fennec build sans MOZ_CRASHREPORTER r=droeh

Dylan Roeh (:droeh) has approved the revision.
Attachment #9008498 - Flags: review+
Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e6b25c0709ad
Fix Fennec build sans MOZ_CRASHREPORTER r=droeh
https://hg.mozilla.org/mozilla-central/rev/e6b25c0709ad
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Blocks: 1506690
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 64 → mozilla64
Version: Firefox 63 → 63 Branch
You need to log in before you can comment on or make changes to this bug.