enable search engines per list.json

RESOLVED DUPLICATE of bug 1496075

Status

enhancement
P2
normal
RESOLVED DUPLICATE of bug 1496075
7 months ago
3 months ago

People

(Reporter: mixedpuppy, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
We include all search engines by default, and enable them per list.json[1].  We need to update this to

- point at xpi instead of xml
- enable/disable engine extensions as necessary

System extensions are typically enabled/disabled via pref in a ad-hoc fashion.  Bug 1489527 aims to resolve that, so we may make use of this, but that is yet to be determined.  We may just enable/disable directly from the search service as necessary.


[1] https://searchfox.org/mozilla-central/rev/a23c3959b62cd3f616435e02810988ef5bac9031/browser/components/search/searchplugins/list.json
(Reporter)

Updated

7 months ago
Blocks: 1486811
(Reporter)

Updated

7 months ago
See Also: → 1491074
(Reporter)

Updated

7 months ago
Priority: -- → P2
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1496075
You need to log in before you can comment on or make changes to this bug.