Closed Bug 1491120 Opened 3 years ago Closed 3 years ago

Crash in std::alloc::rust_oom | webrender::prim_store::PrimitiveStore::add_primitive

Categories

(Core :: Graphics: WebRender, defect, P3)

64 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- disabled
firefox65 --- unaffected

People

(Reporter: jan, Unassigned)

References

(Blocks 3 open bugs)

Details

(Keywords: crash, nightly-community, regression)

Crash Data

Nvidia, GK107 [GeForce GT 640], "wrQualified":{"status":"available"}

This bug was filed from the Socorro interface and is
report bp-25101a76-bf51-466a-b93d-4792b0180913.
> EXCEPTION_ACCESS_VIOLATION_READ
=============================================================

Top 10 frames of crashing thread:

0 xul.dll static void std::alloc::rust_oom src/libstd/alloc.rs:137
1 xul.dll static struct webrender::prim_store::PrimitiveIndex webrender::prim_store::PrimitiveStore::add_primitive gfx/webrender/src/prim_store.rs:1471
2 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::add_primitive gfx/webrender/src/display_list_flattener.rs:873
3 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::flatten_items gfx/webrender/src/display_list_flattener.rs:292
4 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::flatten_items gfx/webrender/src/display_list_flattener.rs:292
5 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::flatten_root gfx/webrender/src/display_list_flattener.rs:255
6 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::flatten_iframe gfx/webrender/src/display_list_flattener.rs:485
7 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::flatten_items gfx/webrender/src/display_list_flattener.rs:292
8 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::flatten_items gfx/webrender/src/display_list_flattener.rs:292
9 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::flatten_root gfx/webrender/src/display_list_flattener.rs:255

=============================================================
Blocks: wr-stability
There are 8 crashes (from 3 installations) in nightly 64 with buildid 20180913100107. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1490282.
:jrmuizel, could you investigate please ?

[1] https://hg.mozilla.org/mozilla-central/rev?node=cd04aed8011f
Blocks: clouseau, 1490282
Flags: needinfo?(jmuizelaar)
Keywords: regression
Priority: P3 → P4
Flags: needinfo?(jmuizelaar)
Jeff -- I'm moving this to P3.  Is there someone else who can look at this?
Flags: needinfo?(jmuizelaar)
Priority: P4 → P3
Moving the need-info to kvark
Flags: needinfo?(jmuizelaar) → needinfo?(kvark)
I'd be happy to, but I'd really like to finish the backface-visibility story first (not to mention there are 2 other bugs in the queue after it, at least, but they can be pushed back a bit).

somewhat related by not really the cause of it,
> self.prim_store.primitives.reserve(self.prim_count_estimate);

This reserves more items than we need. Should be using `pipeline.display_list.prim_count_estimate();` instead.
Flags: needinfo?(kvark)
Crashes with this signature haven't been seen on Nightly builds since 2018-09-18. Can we close this?
Flags: needinfo?(jmuizelaar) → needinfo?(kats)
Sure. If it comes back we can investigate.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(kats)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.