Exiting full-screen HTML5 video also exits Browser full-screen mode

RESOLVED DUPLICATE of bug 1466864

Status

()

defect
RESOLVED DUPLICATE of bug 1466864
7 months ago
7 months ago

People

(Reporter: colin.templeman, Unassigned)

Tracking

(Blocks 1 bug)

62 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180912141329

Steps to reproduce:

1. Maximise Firefox
2. Visit video site (youtube, Daily Motion etc).
3. Select a video and press to play full-screen.
4. During or after video plays, exit video full-screen


Actual results:

Firefox also reduces so it is no longer maximised to full-screen.


Expected results:

Firefox remains maximised in full-screen mode.
(Reporter)

Comment 1

7 months ago
I am reporting this bug on Xubuntu 18.04 Bionic (amd64, kernel 4.15.0-34, XFCE).  With reference to bug #947854, user 'didli' also reported the issue manifesting on Fedora 28 (amd64, XFCE) using Firefox 60.0.2.  The dev requested a new bug be opened but it appears this wasn't done.

PLEASE NOTE: I have also confirmed this behaviour in Nightly 64.0a1 build 20180914220208
(Works fine on Debian Testing (KDE, Xorg), both with a maximized and full screen window.)
(Reporter)

Comment 3

7 months ago
My apologies.  In copying from my notes into the Bugzilla form I missed a salient point (I don't seem to be able to edit the original submission.  If this is possible please let me know how).  For aesthetic reasons I have disabled the Title bar from the customise menu.  If the Title bar is present, this fault does not manifest.  Without the Title bar then this regression as reported is valid.


**UPDATE**
Steps to reproduce:

0. From Firefox Menu, select Customise... and deselect (un-tick) the Title bar option at the bottom-left of the screen.
1. Maximise Firefox
2. Visit video site (youtube, Daily Motion etc).
3. Select a video and press to play full-screen.
4. During or after video plays, exit video full-screen


Actual results:

Firefox also reduces so it is no longer maximised to full-screen.


Expected results:

Firefox remains maximised in full-screen mode.
Blocks: gtktitlebar
Component: Untriaged → Widget: Gtk
OS: Unspecified → Linux
Product: Firefox → Core

Comment 4

7 months ago
Seems to be a duplicate of Bug 1466864.
The fix from XFCE probably hasn't landed in Xubuntu yet.
(Reporter)

Comment 5

7 months ago
Thank you and I concur.  My search of Bugzilla did not yield this fault prior to opening so I will close this off.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1466864
You need to log in before you can comment on or make changes to this bug.