Closed Bug 1491601 Opened Last year Closed Last year

TypeError: frame is undefined subdialogs.js:355:5, on resizing a preferences subdialogue, like about:config

Categories

(Thunderbird :: Preferences, defect)

defect
Not set

Tracking

(thunderbird_esr6063+ fixed, thunderbird63 wontfix, thunderbird64 fixed)

RESOLVED FIXED
Thunderbird 64.0
Tracking Status
thunderbird_esr60 63+ fixed
thunderbird63 --- wontfix
thunderbird64 --- fixed

People

(Reporter: jorgk, Assigned: Paenglab)

Details

Attachments

(2 files, 1 obsolete file)

I came here from bug 1491562 comment #8. Already broken in TB 60 ESR.
We should look at this one one day.
Flags: needinfo?(acelists)
I've got this.
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(acelists)
Attachment #9015102 - Flags: review?(jorgk)
Attached patch 1491601-subdialog.patch (obsolete) — Splinter Review
You beat me. I synchronized subdialogs.js with the m-c version.
Comment on attachment 9015103 [details] [diff] [review]
1491601-subdialog.patch

Review of attachment 9015103 [details] [diff] [review]:
-----------------------------------------------------------------

Geoff and Richard, I prefer to keep in sync with FF as much as we can here. Apart from one hunk, this seems reasonable. Could you please cast an eye onto it. Thanks.

r+ with the comment addressed.

::: mail/components/preferences/subdialogs.js
@@ +276,5 @@
> +    //
> +    // In that case, we expect them to define a Promise which will delay measuring
> +    // until the promise is fulfilled.
> +    if (aEvent.target.contentDocument.mozSubdialogReady) {
> +      await aEvent.target.contentDocument.mozSubdialogReady;

I tried this the other day when looking for the missing Fluent labels and that doesn't work, so we can't port it.
Attachment #9015103 - Flags: review+
Attachment #9015103 - Flags: feedback?(geoff)
Comment on attachment 9015102 [details] [diff] [review]
1491601-subdialogs-undefined-1.diff

Thanks, I prefer the other patch if you approve.
Attachment #9015102 - Flags: review?(jorgk) → review+
Maybe we can use the "small" solution for TB 60 since keeping in sync is not required there.
Addressed comment. I saw no difference with or without this hunk, especially in the Fonts dialog.

Carrying over the r+ and f? from previous patch but waiting for the check-in needed.
Attachment #9015103 - Attachment is obsolete: true
Attachment #9015103 - Flags: feedback?(geoff)
Attachment #9015105 - Flags: review+
Attachment #9015105 - Flags: feedback?(geoff)
(In reply to Richard Marti (:Paenglab) from comment #7)
> Addressed comment. I saw no difference with or without this hunk, ...
When operating the language alternatives menu, you get this in the error console (and the debug windows if you have one):
TypeError: aEvent.target.contentDocument is undefined; can't access its "mozSubdialogReady" property - subdialogs.js:279:5

As I said, I saw this the other day when I was looking for the missing Fluent strings.
Attachment #9015102 - Flags: approval-comm-esr60+
Confirmed working in ESR build.
Attachment #9015102 - Flags: approval-comm-beta+
Attachment #9015105 - Flags: feedback?(geoff) → feedback+
Might as well assign this to somebody who made a decent effort. :)
Assignee: geoff → richard.marti
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/eaaaf728d1d6
Synchronize subdialog.js with M-C to fix JS TypeError. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
You need to log in before you can comment on or make changes to this bug.