closing last tab should do...something

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: crazed_cowboy, Assigned: jag-mozilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

if "hide the tab bar if only one tab is open" is left UNCHECKED (that is, you
see the tab if you only have one tab)....and you click the "x", nothing happens.

something should happen.  i'm not sure what, but something should.  some options
are:
a) return an error message
b) close the last tab, leaving the mozilla window grey and empty
c) close the last tab, but open a new tab for your home page.
d) i guess that not actually closing it may be a valid option for some people...

personally, i like option (c), and option (b) is a good runner-up.  i think the
best solution for this, however, would be to make it an option in the preferences.

Reproducible: Always
Steps to Reproduce:
1. disable "hide the tab bar if only one tab is open"
2. make sure only one tab is open
3. click the "X" to close that tab

Actual Results:  absolutely nothing

Expected Results:  something.  preferably something i told it to do in the
preferences.

Comment 1

17 years ago
sounds like bug 109651 and several duplicates:
The little "x" should be disabled when there's only one tab left in this
situation. Is that not the case? Which theme are you using?
(Reporter)

Comment 2

17 years ago
i'm using the modern theme.  it IS disabled (as in it does nothing), but not
visually.  personally, i'd rather it did *something*.
(Assignee)

Comment 3

17 years ago
Try a more recent trunk build, it should actually look disabled.

Comment 4

17 years ago
There was a regression where the close button no longer appeared as disabled,
fixed in bug 137708 on May 29th. Now the close button does "do something" again:
It changes appearance to disabled.

"Closing things" is what close-buttons do. If it should do something beyond
changing appearance from enabled to disabled, it ought to close the whole
window.

Such a behaviour would likely cause unwanted situations though, where rapidly
clicking the x to close many tabs in succession suddenly take out the whole
window as well.

Since the current behaviour is as designed, and this is not an RFE:
Resolving as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.