Closed Bug 1492175 Opened Last year Closed Last year

Add a pref for hiding the global content blocking toggle

Categories

(Firefox :: Protections UI, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox63 --- fixed
firefox64 --- fixed

People

(Reporter: johannh, Assigned: johannh)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy-panel-64])

Attachments

(1 file)

We are currently considering a few scenarios for the rollout of FastBlock in 63, and if we end up not enabling anything by default for now, it would be beneficial to hide the global toggle from the app menu and about:preferences to not give the user the impression that stuff is turned on when it actually isn't.

We already added this pref once in bug 1472535 and ended up not using it, let's hope for the same this time.
Comment on attachment 9009969 [details]
Bug 1492175 - Add a pref for hiding the global content blocking toggle. r=nhnt11

Nihanth Subramanya [:nhnt11] has approved the revision.
Attachment #9009969 - Flags: review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5018d8cc1578
Add a pref for hiding the global content blocking toggle. r=nhnt11
https://hg.mozilla.org/mozilla-central/rev/5018d8cc1578
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Comment on attachment 9009969 [details]
Bug 1492175 - Add a pref for hiding the global content blocking toggle. r=nhnt11

Approval Request Comment
[Feature/Bug causing the regression]: None
[User impact if declined]: None for now, this patch allows us to avoid inconsistent UX depending on the decision for shipping FastBlock in 63
[Is this code covered by automated tests?]: Not the pref itself but the UI that it hides is well-tested.
[Has the fix been verified in Nightly?]: It works for me.
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: This patch should not do anything by default, it only adds a pref to remove some UI (the global content blocking toggle) that would be inconsistent if we decided to ship content blocking with no blocker on by default. This pref used to exist already before we removed it in 63, now we're adding it back in. The patch has baked in Nightly for a bit.
[String changes made/needed]: None
Attachment #9009969 - Flags: approval-mozilla-beta?
Comment on attachment 9009969 [details]
Bug 1492175 - Add a pref for hiding the global content blocking toggle. r=nhnt11

P1 for a feature we may ship in 63, uplift approved for 63 beta 10, thanks.
Attachment #9009969 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.