Closed Bug 1493203 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] Addon debug targets are not updated for remote devices

Categories

(DevTools :: about:debugging, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1506581

People

(Reporter: jdescottes, Unassigned)

Details

Setting this as unconfirmed as I haven't had time to verify it but reading the code:

https://searchfox.org/mozilla-central/rev/0b8ed772d24605d7cb44c1af6d59e4ca023bd5f5/devtools/client/aboutdebugging-new/src/middleware/debug-target-listener.js#59

  AddonManager.addAddonListener(extensionsListener);

We are always attaching the addon listener to the current instance's addonManager, so the listener will not be called when the list of addons is update on the remote device!
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1506581
No longer blocks: remote-debugging-ng-m2
Priority: P3 → --
You need to log in before you can comment on or make changes to this bug.