Closed Bug 1506581 Opened 9 months ago Closed 9 months ago

[remote-dbg-next] Update list of addons for USB runtimes

Categories

(DevTools :: about:debugging, enhancement, P1)

enhancement

Tracking

(firefox65 fixed)

RESOLVED FIXED
Firefox 65
Tracking Status
firefox65 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Blocked on Bug #1495381

Currently we listen to the addon-manager in order to update our list of addons. We should instead listen to updates on the devtools client so that it can work both in local and remote debugging
Duplicate of this bug: 1493203
Blocks: 1506770
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e664ea614791
Listen to all possible AddonManager events in BrowserAddonList;r=ochameau
https://hg.mozilla.org/integration/autoland/rev/3808928279aa
Listen to addons list changes on DevTools client instead of AddonManager;r=daisuke
https://hg.mozilla.org/integration/autoland/rev/0a38b015f953
Add mochitest to test updates of the addon list for USB runtimes;r=daisuke
https://hg.mozilla.org/mozilla-central/rev/e664ea614791
https://hg.mozilla.org/mozilla-central/rev/3808928279aa
https://hg.mozilla.org/mozilla-central/rev/0a38b015f953
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.