Closed Bug 1493330 Opened 3 years ago Closed 2 years ago

Firefox shows black window and no dialog text in macOS Mojave

Categories

(Core :: Widget: Cocoa, defect)

64 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1494022

People

(Reporter: juniorrubyist, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

Attached image Firefox Screenshot
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0 Safari/605.1.15

Steps to reproduce:

I upgraded to the latest macOS Mojave PB and opened Firefox 62.0.2.


Actual results:

A black screen opened.


Expected results:

Firefox should've shown normally.
Workaround - Disabling Dark Interface:
Open Terminal
Run `defaults write -g NSRequiresAquaSystemAppearance -bool YES`
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Does this still happen with the latest nightly?

https://www.mozilla.org/en-US/firefox/channel/desktop/#nightly
Flags: needinfo?(juniorrubyist)
I have this bug too, it still happens with Nightly (64.01a).

The above terminal command solution does take away the problem for both Firefox (62.02) and Nightly.
To fix, enter in terminal:
defaults write -g NSRequiresAquaSystemAppearance -bool YES
killall Dock
killall Finder

Then restart Firefox. It will still change to dark/light with the system appearance, but other aspects of Mac OS Dark mode will be limited. It is also worth noting that many other apps have a similar issue as well regarding this terminal command as part of the solution. Some include: Google Chrome menus, Powerpoint menus, MS Word menus, and AppCleaner. Each of these have had text that is white and illegible when dark mode is enabled.

I would also like to point out that, interestingly, the Blackout bug does not affect a guest account regardless of the terminal command or dark/white mode (for me at least).
I have tested it with Nightly, thinking this bug was already reported.
Flags: needinfo?(juniorrubyist)
Version: 62 Branch → 64 Branch
Just wondering, has any progress been made on this yet?
Flags: needinfo?(mstange)
Not that I know of, no.
Flags: needinfo?(mstange)
Hey, I found this to be a better workaround, possibly the solution:

defaults delete -g NSRequiresAquaSystemAppearance
killall Dock Finder

This keeps the dark mode on everything and allows Firefox to work normally.

I'll wait till more info is given on the black thing before marking it invalid.
Blocks: mojave
Does /Applications/Utilities/Console.app print anything interesting when this problem occurs? I'm updating my system right now and will try to reproduce.
Flags: needinfo?(juniorrubyist)
Here's everything logged from when it opens (filtered for `firefox`)


default	13:14:21.561003 -0700	firefox	LSExceptions shared instance invalidated for timeout.
default	13:14:23.174445 -0700	loginwindow	-[PersistentAppsSupport saveLogoutPersistentState:finalSnapshot:] |      checkAgainstApp is : Firefox Nightly
default	13:14:23.174458 -0700	loginwindow	-[PersistentAppsSupport appShouldBeRelaunched:] | entered. checking app: Firefox Nightly
default	13:14:28.399440 -0700	loginwindow	-[PersistentAppsSupport applicationQuit:] | for app:Firefox NightlyCP, _appTrackingState = 2
default	13:14:28.406158 -0700	loginwindow	-[PersistentAppsSupport applicationQuit:] | for app:Firefox NightlyCP, _appTrackingState = 2
default	13:14:28.457301 -0700	loginwindow	-[PersistentAppsSupport applicationQuit:] | for app:Firefox NightlyCP, _appTrackingState = 2
default	13:14:28.745610 -0700	loginwindow	-[PersistentAppsSupport applicationQuit:] | for app:Firefox Nightly, _appTrackingState = 2
default	13:14:28.745638 -0700	loginwindow	-[PersistentAppsSupport applicationQuit:] | App: Firefox Nightly, quit, updating active tracking timer
default	13:14:53.703853 -0700	lsd	Non-fatal error enumerating at <private>, continuing: Error Domain=NSCocoaErrorDomain Code=260 "The file “PlugIns” couldn’t be opened because there is no such file." UserInfo={NSURL=PlugIns/ -- file:///Users/joseph/Applications/Firefox%20Nightly.app/Contents/, NSFilePath=/Users/joseph/Applications/Firefox Nightly.app/Contents/PlugIns, NSUnderlyingError=0x7fd75af85370 {Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"}}
default	13:14:53.738032 -0700	loginwindow	-[PersistentAppsSupport applicationReady:] | App: Firefox Nightly, ready, updating active tracking timer
default	13:14:53.738085 -0700	loginwindow	-[ApplicationManager checkInAppContext:refCon:eventData:] |      checked in app : Firefox Nightly
default	13:14:53.817704 -0700	loginwindow	-[ApplicationManager checkInAppContext:refCon:eventData:] |      checked in app : Firefox Nightly
default	13:14:53.823415 -0700	lsd	Non-fatal error enumerating at <private>, continuing: Error Domain=NSCocoaErrorDomain Code=260 "The file “PlugIns” couldn’t be opened because there is no such file." UserInfo={NSURL=PlugIns/ -- file:///Users/joseph/Applications/Firefox%20Nightly.app/Contents/, NSFilePath=/Users/joseph/Applications/Firefox Nightly.app/Contents/PlugIns, NSUnderlyingError=0x7fd75af6d3e0 {Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"}}
default	13:14:53.850579 -0700	firefox	Current system appearance, (HLTB: 2), (SLS: 1)
default	13:14:53.855108 -0700	firefox	Post-registration system appearance: (HLTB: 2)
error	13:14:53.866354 -0700	firefox	Unable to load Info.plist exceptions (eGPUOverrides)
default	13:14:53.905172 -0700	firefox	NSApp cache appearance:
-NSRequiresAquaSystemAppearance: 0
-appearance: (null)
-effectiveAppearance: <NSCompositeAppearance: 0x10b102740
 (
    "<NSDarkAquaAppearance: 0x10b103600>",
    "<NSSystemAppearance: 0x10b103840>"
)>
default	13:14:54.101090 -0700	loginwindow	-[PersistentAppsSupport applicationReady:] | App: Firefox Nightly, ready, updating active tracking timer
default	13:14:54.121327 -0700	tccd	-[TCCDAccessIdentity staticCode]: static code for: identifier org.mozilla.nightly, type: 0: 0x7f8945f12d40 at /Users/joseph/Applications/Firefox Nightly.app
default	13:14:54.130670 -0700	lsd	Non-fatal error enumerating at <private>, continuing: Error Domain=NSCocoaErrorDomain Code=260 "The file “PlugIns” couldn’t be opened because there is no such file." UserInfo={NSURL=PlugIns/ -- file:///Users/joseph/Applications/Firefox%20Nightly.app/Contents/, NSFilePath=/Users/joseph/Applications/Firefox Nightly.app/Contents/PlugIns, NSUnderlyingError=0x7fb7bc018730 {Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"}}
default	13:14:54.135333 -0700	lsd	Non-fatal error enumerating at <private>, continuing: Error Domain=NSCocoaErrorDomain Code=260 "The file “PlugIns” couldn’t be opened because there is no such file." UserInfo={NSURL=PlugIns/ -- file:///Users/joseph/Applications/Firefox%20Nightly.app/Contents/, NSFilePath=/Users/joseph/Applications/Firefox Nightly.app/Contents/PlugIns, NSUnderlyingError=0x7fb7b9d8b560 {Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"}}
default	13:14:54.433766 -0700	loginwindow	-[ApplicationManager checkInAppContext:refCon:eventData:] |      checked in app : Firefox NightlyCP
error	13:14:54.459400 -0700	plugin-container	Unable to load Info.plist exceptions (eGPUOverrides)
default	13:14:54.486635 -0700	plugin-container	Current system appearance, (HLTB: 2), (SLS: 1)
default	13:14:54.490035 -0700	plugin-container	Post-registration system appearance: (HLTB: 2)
default	13:14:54.500176 -0700	plugin-container	NSApp cache appearance:
-NSRequiresAquaSystemAppearance: 0
-appearance: (null)
-effectiveAppearance: <NSCompositeAppearance: 0x10c4446f0
 (
    "<NSDarkAquaAppearance: 0x10c4427c0>",
    "<NSSystemAppearance: 0x10c442a00>"
)>
default	13:14:54.606855 -0700	plugin-container	CGSConnection: serious error: CID 902167 is dead.
default	13:14:54.606881 -0700	plugin-container	CGSConnection: current backtrace:: Backtrace (at 0):
default	13:14:54.606893 -0700	plugin-container	CGSConnection: creation backtrace:: Backtrace (at 0):
default	13:14:54.606906 -0700	plugin-container	CGSConnection: destruction backtrace:: Backtrace (at 0):
default	13:14:54.606929 -0700	plugin-container	Invalid Connection ID 902167
default	13:14:54.606941 -0700	plugin-container	Set a breakpoint at SLSLogBreak to catch errors/faults as they are logged.
error	13:14:54.606953 -0700	plugin-container	SLSGetSpaceManagementMode: No connection with id 0x   dc417
error	13:14:54.701425 -0700	firefox	        AEGetDescData of non-desc type 'reco' not a good idea
default	13:14:54.880775 -0700	loginwindow	-[ApplicationManager checkInAppContext:refCon:eventData:] |      checked in app : Firefox NightlyCP
error	13:14:54.903188 -0700	plugin-container	Unable to load Info.plist exceptions (eGPUOverrides)
default	13:14:54.929475 -0700	plugin-container	Current system appearance, (HLTB: 2), (SLS: 1)
default	13:14:54.932897 -0700	plugin-container	Post-registration system appearance: (HLTB: 2)
default	13:14:54.942453 -0700	plugin-container	NSApp cache appearance:
-NSRequiresAquaSystemAppearance: 0
-appearance: (null)
-effectiveAppearance: <NSCompositeAppearance: 0x115a66c40
 (
    "<NSDarkAquaAppearance: 0x115a6a7c0>",
    "<NSSystemAppearance: 0x115a6aa00>"
)>
default	13:14:55.087066 -0700	plugin-container	CGSConnection: serious error: CID 646447 is dead.
default	13:14:55.087080 -0700	plugin-container	CGSConnection: current backtrace:: Backtrace (at 0):
default	13:14:55.087092 -0700	plugin-container	CGSConnection: creation backtrace:: Backtrace (at 0):
default	13:14:55.087103 -0700	plugin-container	CGSConnection: destruction backtrace:: Backtrace (at 0):
default	13:14:55.087114 -0700	plugin-container	Invalid Connection ID 646447
default	13:14:55.087165 -0700	plugin-container	Set a breakpoint at SLSLogBreak to catch errors/faults as they are logged.
error	13:14:55.087227 -0700	plugin-container	SLSGetSpaceManagementMode: No connection with id 0x   9dd2f
default	13:14:55.489282 -0700	loginwindow	-[ApplicationManager checkInAppContext:refCon:eventData:] |      checked in app : Firefox NightlyCP
error	13:14:55.517886 -0700	plugin-container	Unable to load Info.plist exceptions (eGPUOverrides)
default	13:14:55.550342 -0700	plugin-container	Current system appearance, (HLTB: 2), (SLS: 1)
default	13:14:55.554946 -0700	plugin-container	Post-registration system appearance: (HLTB: 2)
default	13:14:55.566516 -0700	plugin-container	NSApp cache appearance:
-NSRequiresAquaSystemAppearance: 0
-appearance: (null)
-effectiveAppearance: <NSCompositeAppearance: 0x113d5b1a0
 (
    "<NSDarkAquaAppearance: 0x113d54880>",
    "<NSSystemAppearance: 0x113d54ac0>"
)>
default	13:14:55.696729 -0700	plugin-container	FolderManager: Failed looking up user domain root; url='file:///Users/joseph/' path=- err=-1 uid=502 euid=502
default	13:14:55.696797 -0700	plugin-container	FolderManager: Failed looking up user domain root; url='file:///Users/joseph/' path=- err=-1 uid=502 euid=502
default	13:14:55.696859 -0700	plugin-container	FolderManager: Failed looking up user domain root; url='file:///Users/joseph/' path=- err=-1 uid=502 euid=502
default	13:14:56.306920 -0700	plugin-container	FolderManager: Failed looking up user domain root; url='file:///Users/joseph/' path=- err=-1 uid=502 euid=502
default	13:14:56.306992 -0700	plugin-container	FolderManager: Failed looking up user domain root; url='file:///Users/joseph/' path=- err=-1 uid=502 euid=502
default	13:14:56.307050 -0700	plugin-container	FolderManager: Failed looking up user domain root; url='file:///Users/joseph/' path=- err=-1 uid=502 euid=502
default	13:14:59.104560 -0700	loginwindow	-[PersistentAppsSupport saveLogoutPersistentState:finalSnapshot:] |      checkAgainstApp is : Firefox Nightly
default	13:14:59.104574 -0700	loginwindow	-[PersistentAppsSupport appShouldBeRelaunched:] | entered. checking app: Firefox Nightly
default	13:14:59.104596 -0700	loginwindow	-[PersistentAppsSupport saveLogoutPersistentState:finalSnapshot:] |           Adding to relaunchArray: Firefox Nightly
default	13:14:59.109143 -0700	loginwindow	-[PersistentAppsSupport saveLogoutPersistentState:finalSnapshot:] |           Contents:(
        {
        BackgroundState = 2;
        BundleID = "com.apple.console";
        Hide = 0;
        Path = "/Applications/Utilities/Console.app";
    },
        {
        BackgroundState = 2;
        BundleID = "org.mozilla.nightly";
        Hide = 0;
        Path = "/Users/joseph/Applications/Firefox Nightly.app";
    },
        {
        BackgroundState = 2;
        BundleID = "com.googlecode.iterm2";
        Hide = 0;
        Path = "/Users/joseph/Applications/iTerm.app";
    },
        {
        BackgroundState = 2;
        BundleID = "com.gravit.mac.designer";
        Hide = 0;
        Path = "/Users/joseph/Applications/GravitDesigner.app";
    },
        {
        BackgroundState = 2;
        BundleID = "com.microsoft.outlook";
        Hide = 0;
        Path = "/Applications/Microsoft Outlook.app";
    },
        {
        BackgroundState = 2;
        BundleID = "com.apple.calculator";
        Hide = 0;
        Path = "/Applications/Calculator.app";
    },
        {
        BackgroundState = 2;
        BundleID = "com.apple.finder";
        Hide = 0;
        Path = "/System/Library/CoreServices/Finder.app";
    }
)
default	13:15:04.106777 -0700	firefox	LSExceptions shared instance invalidated for timeout.
default	13:15:04.494918 -0700	plugin-container	LSExceptions shared instance invalidated for timeout.
default	13:15:04.937683 -0700	plugin-container	LSExceptions shared instance invalidated for timeout.
default	13:15:05.560373 -0700	plugin-container	LSExceptions shared instance invalidated for timeout.
Flags: needinfo?(juniorrubyist)
For anyone who can reproduce this: I'm about to post two Info.plist files. Could you please replace the Info.plist file inside the Firefox.app bundle with each one of these and report which one, if any, still reproduces the issue? The Info.plist file is located at Firefox.app/Contents/. Don't forget to back up the existing Info.plist file so you can revert to it once you are done with this test. Thank you!
Flags: needinfo?(juniorrubyist)
(In reply to Stephen A Pohl [:spohl] from comment #11)
> Created attachment 9013182 [details]
> NSRequiresAquaSystemAppearance - YES

Tried this one, no change. Still see a black window, and grey alert box with no visible content. But clicking where there should be a visible a button performs an action with a resulting OS (I'm assuming) dialog asking to make Firefox my default browser or keep my current default browser.
(In reply to Stephen A Pohl [:spohl] from comment #12)
> Created attachment 9013183 [details]
> NSRequiresAquaSystemAppearance - NO

Tried this one as well, no change. Still see a black window, and grey alert box with no visible content. But clicking where there should be a visible a button performs an action with a resulting OS (I'm assuming) dialog asking to make Firefox my default browser or keep my current default browser.
Seeing this too after compiling.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I tried the various suggestions above (but not the plist replacement), but none worked. Switching to light theme also doesn't seem to help.
(In reply to Marcos Caceres [:marcosc] from comment #15)
> Seeing this too after compiling.

The issue related to compiling with the 10.14 SDK is tracked in bug 1494022. This bug here is related to the same issue in the regular, shipping version of Firefox that we have yet to reproduce in-house.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Everything working here:

- macOS Mojave 10.14.1 Beta 18B73a
- dark theme activated
- Firefox Nightly 65.0a1 (2018-10-25) (64-bit)
- MacBook Pro (Retina, 13-inch, Mid 2014)

FYI: When compiling an OpenGL applications with SDL or GLFW with Xcode 10 and the 10.14 SDK, no rendering happens until the window is resized or moved, not sure if this is related. This seems to be related to some new breakage with NSOpenGLView.
I'm kinda able to reproduce this issue, unfortunately not with a new profile though :/
I only see this issue in the sidebar of the download window so I'm not 100% sure if that's the same issue or not.
I tried to deactivate Dark mode (which I had enabled) but that doesn't fix it.
If there's anything I can help with, I love to do that.
I am able to reproduce the same behavior as Patrick.

- MacBook Pro (2017, 15-inch, Mid 2017)
- Dark Theme activated
- Firefox Nightly 65.0a1 (Build ID: 20181028102553)
- MacOS Mojave 10.14 (18A391)

Will provide more information on request.
The people who can reproduce this issue... what is the value of the gfx.compositor.glcontext.opaque pref in about:config?
Confirming I’m seeing this on a MacBook Pro with Firefox 63.

Mike, gfx.compositor.glcontext.opaque is false.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I see it fixed in latest build (65.0a1 (2018-11-01)). I had the same problem.
Hello,

Same problem for me: Mojave 10.14.1, test whit firefox stable, beta @ developper ... black screen with all.

MacBook Air (13-inch, Early 2015) 1,6 GHz Intel Core i5, 8 Go 1600 MHz DDR3, Intel HD Graphics 6000 1536 Mo
Hello, 

Same result if gfx.compositor.glcontext.opaque is true or false.
Greetings,

I had this issue previously even up to the latest Mac OS public beta build in October. Using a guest account or another user would not reproduce the issue I had on my main account (the black blank screen).

The ONLY thing that worked for me after trying everything else was to completely wipe/erase my Mac OS partition and reinstall Mojave using a USB. Before this, I had reinstalled the OS while preserving user data, this changed nothing. Migrating to a 2nd user would create multiple file permissions issues that could not be easily resolved unfortunately.

This issue started when I installed the public beta near the beginning of September from High Sierra.
I managed to get around this problem using Mattn's trick of downloading an old SDK (MacOSX10.11.sdk) from [1], and then adding the following .mozconfig: 

```
ac_add_options --with-macos-sdk=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.11.sdk

```

I didn't try with newer SDKs. 

Note that the SDK can't be symlinked for some reason (for me at least). I had to place it at the location above.  

[1] https://github.com/phracker/MacOSX-SDKs
Due to another build failure I did an upgrade and hit this issue, Marcos' workaround fixed it for me, non of the defaults changes did.

Seems like low traffic for what seems like a pretty large bug, we cant build a usable firefox on the latest default build of osx or is this not happening to everyone building on mojave?
(In reply to Dale Harvey (:daleharvey) from comment #28)
> Due to another build failure I did an upgrade and hit this issue, Marcos'
> workaround fixed it for me, non of the defaults changes did.
> 
> Seems like low traffic for what seems like a pretty large bug, we cant build
> a usable firefox on the latest default build of osx or is this not happening
> to everyone building on mojave?

See comment 17.
if you wanna full dark mode with firefox without black screen, you must only write in the terminal: 

defaults write org.mozilla.firefox NSRequiresAquaSystemAppearance 1

see discussion posted by u/MaresDoOrgasm: https://www.reddit.com/r/apple/comments/9jr2zy/how_to_enable_mojave_dark_mode_for_applications/

only change 0 to 1

Don't need logout

luck! <3 
reverse :p
I seem to get a similar issue after building locally on Mojave, The console only has:

Can't find symbol 'GetGraphicsResetStatus'.
I tried all of this, still I see only black screen. Help me please.
(In reply to Yura Zenevich [:yzen] from comment #31)
> I seem to get a similar issue after building locally on Mojave, The console
> only has:
> 
> Can't find symbol 'GetGraphicsResetStatus'.

This error message seems like false alarm of Bug 1514985.
(In reply to Yura Zenevich [:yzen] from comment #31)
> I seem to get a similar issue after building locally on Mojave, The console
> only has:
> 
> Can't find symbol 'GetGraphicsResetStatus'.

I saw the same problem. It was addressed by Comment 27 for me.
This bug is being overwhelmed with comments related to building with the 10.14 SDK. We have yet to get confirmation that this is an issue in the currently shipping versions of Firefox. As such, I'm closing this bug as a duplicate of bug 1494022.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(juniorrubyist)
Resolution: --- → DUPLICATE
Duplicate of bug: 1494022
You need to log in before you can comment on or make changes to this bug.