Closed Bug 1493999 Opened 3 years ago Closed 3 years ago

Windows symbols missing since Microsoft's September patch day

Categories

(Socorro :: Symbols, task)

Unspecified
Windows
task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: philipp, Assigned: ted)

References

Details

+++ This bug was initially created as a clone of Bug #1486825 +++

the latest report of missing signatures is highlighting a number of windows system dll symbols across various versions of the os:

Name 	Version 	Debug ID 	# of crash reports
ntdll.dll	10.0.17134.254	5BADA6763A2DF568BAEAC8F70DA0DF3C1	47469
ucrtbase.dll	10.0.17134.254	1C53BB2C2F5D54A655C8CEE1F4CCBD4B1	47348
ntdll.dll	6.1.7601.24231	B83325CB67964070AB709DD5B4AA70C31	16691
KERNELBASE.dll	6.1.7601.24231	A32B095FBEA047809684FAD7061BEA562	16685
kernel32.dll	6.1.7601.24231	688985C0502946FC8D8EE2E41F8B31AC2	16676
ntdll.dll	6.1.7601.24231	BD14E8F854B944CABFED8201BE5AE40A2	14165
ucrtbase.dll	10.0.17134.254	08A2EF04ED46F71846F69333018A073A1	12132
ntdll.dll	10.0.17134.254	D3AE91CEDD9309EF777F2FD5120010BE1	8911
ntdll.dll	6.1.7601.24231	8D861C26D6FA45B3BD8751D088E9648C2	8812
kernel32.dll	6.1.7601.24231	716DC733953C48A59A00087BD2EB59F42	8798
ntdll.dll	10.0.17134.254	ACBCC16F0B619A1EF190C1255641393B1	5153

the problem is apparent since the latest ms patchday in september and it's mainly affecting the proper signature generation for shutdownhangs.
sorry to bug, could you look into this?
Flags: needinfo?(ted)
I once again manually uploaded symbols from the latest fetch-win32-symbols task:
https://symbols.mozilla.org/uploads/upload/31541
https://tools.taskcluster.net/groups/NpoldGQCTCe7c1Sbb6eO2g/tasks/Ri1E5q5qT3m3zoXQdFcjIA/runs/0/logs/public%2Flogs%2Flive.log
Assignee: nobody → ted
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(ted)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.