Closed Bug 1494008 Opened 2 years ago Closed 2 years ago

"Default" Theme not applying while Mac appearance is set to "Dark." "Default" Firefox theme displays "Dark" Firefox theme.

Categories

(Firefox :: Theme, defect)

62 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1474591

People

(Reporter: bsimonelli125, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180920131237

Steps to reproduce:

On the latest version of Mac OS X, open System Preferences and click General. At the top, select the "Dark" as the system appearance. Close System Preferences.

Open a new window of the latest version of Firefox and open the menu (hamburger menu on the right side of the toolbar) and click "Customize..."

At the bottom of the "Customize Firefox" tab that opens, there is a "Themes" box. Click it and select "Default." You should notice that the Default theme is previewing correctly, while the mouse is hovering over the "Default" option, but once clicked, the theme will be solid black across the top, clearly displaying the "Dark" theme, despite selecting "Default." Now change the theme to "Dark," and you'll see that nothing changes when switching between the two themes. "Light" theme works as expected.


Actual results:

The "Dark" theme appears even when the "Default" theme is enabled while the Mac system appearance is set to "Dark." The "Default," "Light," and "Dark" themes in Firefox all work as expected while the system appearance is set to "Light." The "Default" theme previews correctly while the system appearance is set to "Dark," but once clicked, the "Dark" theme appears.


Expected results:

What should happen is that the "Default" theme should be appear despite what my system appearance is set to. The "Dark" theme in Firefox removes the nice transparency effect at the top of the window in the tab bar, which I really enjoy. Hoping for a fix, or an option to enable the transparency in the "Default" theme within the "Dark" theme.
Component: Untriaged → Theme
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1474591
You need to log in before you can comment on or make changes to this bug.