Closed Bug 1494603 Opened 1 year ago Closed 1 year ago

aggregate initialization of type 'mozilla::gl::GLContextSymbols' with user-declared constructors is incompatible with C++2a [-Werror,-Wc++2a-compat]

Categories

(Core :: Canvas: WebGL, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1495892
Tracking Status
firefox64 --- affected

People

(Reporter: Sylvestre, Unassigned)

References

(Blocks 1 open bug)

Details

Building with clang trunk & -Werror, it is failing with:
<https://relman-ci.moz.tools/job/firefox-clang-lld-last/ws/obj-x86_64-pc-linux-gnu/dist/include/GLContext.h>:3504:33: error: aggregate initialization of type 'mozilla::gl::GLContextSymbols' with user-declared constructors is incompatible with C++2a [-Werror,-Wc++2a-compat]
    GLContextSymbols mSymbols = {};
                                ^~

Because of this change:
https://github.com/llvm-mirror/clang/commit/de8e63fd00e24e58a5ca05007cf7954916a6e6b9
I'm guessing this started happening with the changes in bug 1482974.
Blocks: 1482974
Flags: needinfo?(jgilbert)
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1495892
Flags: needinfo?(jgilbert)
You need to log in before you can comment on or make changes to this bug.