Remove the AllocationHandle API

RESOLVED FIXED in Firefox 68

Status

()

enhancement
P3
normal
RESOLVED FIXED
9 months ago
3 months ago

People

(Reporter: padenot, Assigned: pehrsons)

Tracking

Trunk
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 wontfix, firefox68 fixed)

Details

Attachments

(5 attachments)

Reporter

Description

9 months ago
This is a followup from bug 1487057 part 3, pehrsons wrote in the review:

> We should get a bug on file to kill AllocationHandles and clean up the APIs using it.
Reporter

Updated

9 months ago
Priority: -- → P3
Assignee

Updated

3 months ago
Assignee: nobody → apehrson
Status: NEW → ASSIGNED
Assignee

Comment 1

3 months ago

Sources are no longer shared.

Assignee

Comment 2

3 months ago

The handle was used to keep separate allocations of the same source in a single
process apart. Sources no longer use sharing, so we no longer need allocations
or their handles even as a concept.

Assignee

Comment 3

3 months ago

These once served a caching-and-reuse purpose it seems, but it makes less sense
when sources are not shared.

There seems to still be functioning code to re-use fake audio devices, but this
seems like premature optimization. Especially since we don't care much about
fake devices in release.

This patch removes it all, together with some plumbing around the mechanism.

Depends on: 1525323
Assignee

Comment 4

3 months ago

Bug 1538113 fixed most, but apparently some remained. Unclear why -- perhaps I
ran it with a different config this time.

Comment 6

3 months ago
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9e7832fee028
Remove MediaEngineSource::RequiresSharing. r=padenot
https://hg.mozilla.org/integration/autoland/rev/20543d03a4cd
Remove AllocationHandle. r=padenot
https://hg.mozilla.org/integration/autoland/rev/1248d2f659a9
Remove windowID to MediaEngineSource mappings from MediaEngines. r=padenot
https://hg.mozilla.org/integration/autoland/rev/276622dfadd8
Fix remaining static-analysis warnings in dom/media/webrtc. r=jib
https://hg.mozilla.org/integration/autoland/rev/be0fbe76851f
Merge SourceListener::Remove into SourceListener::Stop. r=padenot
Depends on: 1540434
Regressions: 1540434
You need to log in before you can comment on or make changes to this bug.