Closed Bug 1495012 Opened 11 months ago Closed 11 months ago

Perma-failing [tier2] error: the option `Z` is only accepted on the nightly compiler

Categories

(Firefox Build System :: Toolchains, defect)

defect
Not set

Tracking

(firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: tiberius_oros, Assigned: marco)

References

Details

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=202241851&repo=mozilla-central&lineNumber=3665

[task 2018-09-28T16:07:08.098Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/nspr/pr'
[task 2018-09-28T16:07:08.098Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/nspr/pr'
[task 2018-09-28T16:07:08.098Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/nspr/pr'
[task 2018-09-28T16:07:08.146Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-28T16:07:08.148Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/gcc/bin/g++ -o appendable.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DU_COMMON_IMPLEMENTATION -DUCONFIG_NO_TRANSLITERATION -DUCONFIG_NO_REGULAR_EXPRESSIONS -DUCONFIG_NO_LEGACY_CONVERSION -DU_USING_ICU_NAMESPACE=0 -DU_NO_DEFAULT_INCLUDE_UTF_HEADERS=1 -DU_CHARSET_IS_UTF8 -DU_HAVE_NL_LANGINFO_CODESET=0 -I/builds/worker/workspace/build/src/config/external/icu/common -I/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common -I/builds/worker/workspace/build/src/intl/icu/source/i18n -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation --coverage -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -freorder-blocks -O2 -fomit-frame-pointer -funwind-tables -Wno-deprecated-declarations -Wno-type-limits -Wno-unused-but-set-variable -Wno-unused-function -Wno-sign-compare -Wno-maybe-uninitialized -frtti  -MD -MP -MF .deps/appendable.o.pp   /builds/worker/workspace/build/src/intl/icu/source/common/appendable.cpp
[task 2018-09-28T16:07:08.148Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-28T16:07:08.148Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-28T16:07:08.148Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-28T16:07:08.148Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-28T16:07:08.148Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-28T16:07:08.164Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/js/src/rust'
[task 2018-09-28T16:07:08.165Z] 16:07:08     INFO -  js/src/rust/force-cargo-library-build
[task 2018-09-28T16:07:08.166Z] 16:07:08     INFO -  env    CARGO_TARGET_DIR=/builds/worker/workspace/build/src/obj-firefox/js/src/rust RUSTFLAGS='-C opt-level=2 -C debuginfo=2  -Ccodegen-units=1 -Zprofile -Zno-landing-pads' RUSTC=/builds/worker/workspace/build/src/rustc/bin/rustc RUSTDOC=/builds/worker/workspace/build/src/rustc/bin/rustdoc RUSTFMT=/builds/worker/workspace/build/src/rustc/bin/rustfmt  MOZ_SRC=/builds/worker/workspace/build/src MOZ_DIST=/builds/worker/workspace/build/src/obj-firefox/dist LIBCLANG_PATH="/builds/worker/workspace/build/src/clang/lib" CLANG_PATH="/builds/worker/workspace/build/src/clang/bin/clang" PKG_CONFIG_ALLOW_CROSS=1 RUST_BACKTRACE=full MOZ_TOPOBJDIR=/builds/worker/workspace/build/src/obj-firefox CARGO_INCREMENTAL=0 MOZ_CARGO_WRAP_LDFLAGS="-lpthread --coverage -L/builds/worker/workspace/build/src/clang/lib/clang/7.0.0/lib/linux/ -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-z,nocopyreloc -Wl,--build-id=sha1 -Wl,-rpath-link,/builds/worker/workspace/build/src/obj-firefox/dist/bin -Wl,-rpath-link,/builds/worker/workspace/build/src/obj-firefox/dist/lib" MOZ_CARGO_WRAP_LD=" /builds/worker/workspace/build/src/gcc/bin/gcc -std=gnu99" CARGO_TARGET_X86_64_UNKNOWN_LINUX_GNU_LINKER=/builds/worker/workspace/build/src/build/cargo-linker /builds/worker/workspace/build/src/rustc/bin/cargo rustc  --release --frozen --manifest-path /builds/worker/workspace/build/src/js/src/rust/Cargo.toml -vv --lib --target=x86_64-unknown-linux-gnu  --  -C lto
[task 2018-09-28T16:07:08.166Z] 16:07:08     INFO -  error: failed to run `rustc` to learn about target-specific information
[task 2018-09-28T16:07:08.166Z] 16:07:08     INFO -  Caused by:
[task 2018-09-28T16:07:08.166Z] 16:07:08     INFO -    process didn't exit successfully: `/builds/worker/workspace/build/src/rustc/bin/rustc - --crate-name ___ --print=file-names -C opt-level=2 -C debuginfo=2 -Ccodegen-units=1 -Zprofile -Zno-landing-pads --target x86_64-unknown-linux-gnu --crate-type bin --crate-type rlib --crate-type dylib --crate-type cdylib --crate-type staticlib --crate-type proc-macro` (exit code: 1)
[task 2018-09-28T16:07:08.166Z] 16:07:08     INFO -  --- stderr
[task 2018-09-28T16:07:08.166Z] 16:07:08     INFO -  error: the option `Z` is only accepted on the nightly compiler
[task 2018-09-28T16:07:08.166Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/config/rules.mk:1048: recipe for target 'force-cargo-library-build' failed
[task 2018-09-28T16:07:08.166Z] 16:07:08     INFO -  make[4]: *** [force-cargo-library-build] Error 101
[task 2018-09-28T16:07:08.166Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/js/src/rust'
[task 2018-09-28T16:07:08.168Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/config/recurse.mk:74: recipe for target 'js/src/rust/target' failed
[task 2018-09-28T16:07:08.168Z] 16:07:08     INFO -  make[3]: *** [js/src/rust/target] Error 2
[task 2018-09-28T16:07:08.168Z] 16:07:08     INFO -  make[3]: *** Waiting for unfinished jobs....
[task 2018-09-28T16:07:08.168Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-28T16:07:08.168Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/gcc/bin/gcc -std=gnu99 -o crc32.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -I/builds/worker/workspace/build/src/modules/zlib/src -I/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 --coverage -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread -pipe -g -freorder-blocks -O2 -fomit-frame-pointer -funwind-tables -Wall -Wempty-body -Wignored-qualifiers -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat  -MD -MP -MF .deps/crc32.o.pp   /builds/worker/workspace/build/src/modules/zlib/src/crc32.c
[task 2018-09-28T16:07:08.168Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-28T16:07:08.168Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-28T16:07:08.168Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-28T16:07:08.172Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-28T16:07:08.173Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-28T16:07:08.175Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-28T16:07:08.176Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-28T16:07:08.217Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.221Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/gcc/bin/g++ -o e_asin.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DEXPORT_JS_API -DMOZ_HAS_MOZGLUE -I/builds/worker/workspace/build/src/modules/fdlibm/src -I/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation --coverage -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -freorder-blocks -O2 -fomit-frame-pointer -funwind-tables -Wno-parentheses -Wno-sign-compare  -MD -MP -MF .deps/e_asin.o.pp   /builds/worker/workspace/build/src/modules/fdlibm/src/e_asin.cpp
[task 2018-09-28T16:07:08.222Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.229Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.230Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.230Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.230Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.246Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/memory/volatile'
[task 2018-09-28T16:07:08.246Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/gcc/bin/g++ -o Unified_cpp_memory_volatile0.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -DNDEBUG=1 -DTRIMMED=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/worker/workspace/build/src/memory/volatile -I/builds/worker/workspace/build/src/obj-firefox/memory/volatile -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation --coverage -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -freorder-blocks -O2 -fomit-frame-pointer -funwind-tables  -MD -MP -MF .deps/Unified_cpp_memory_volatile0.o.pp   /builds/worker/workspace/build/src/obj-firefox/memory/volatile/Unified_cpp_memory_volatile0.cpp
[task 2018-09-28T16:07:08.247Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/memory/volatile'
[task 2018-09-28T16:07:08.247Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.247Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.262Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.262Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.299Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/memory/replace/logalloc'
[task 2018-09-28T16:07:08.299Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/gcc/bin/g++ -o LogAlloc.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DMOZ_REPLACE_MALLOC_PREFIX=logalloc -DMOZ_NO_MOZALLOC -DMOZ_HAS_MOZGLUE -I/builds/worker/workspace/build/src/memory/replace/logalloc -I/builds/worker/workspace/build/src/obj-firefox/memory/replace/logalloc -I/builds/worker/workspace/build/src/memory/build -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation --coverage -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -freorder-blocks -O2 -fomit-frame-pointer -funwind-tables  -MD -MP -MF .deps/LogAlloc.o.pp   /builds/worker/workspace/build/src/memory/replace/logalloc/LogAlloc.cpp
[task 2018-09-28T16:07:08.299Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/memory/replace/logalloc'
[task 2018-09-28T16:07:08.299Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.299Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.303Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.304Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.325Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/nspr/pr'
[task 2018-09-28T16:07:08.326Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/gcc/bin/gcc -std=gnu99 -o pripv6.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -D_NSPR_BUILD_ -DHAVE_POINTER_LOCALTIME_R -DHAVE_FCNTL_FILE_LOCKING -D_GNU_SOURCE -DLINUX -D_PR_PTHREADS -I/builds/worker/workspace/build/src/config/external/nspr/pr -I/builds/worker/workspace/build/src/obj-firefox/config/external/nspr/pr -I/builds/worker/workspace/build/src/config/external/nspr -I/builds/worker/workspace/build/src/nsprpub/pr/include -I/builds/worker/workspace/build/src/nsprpub/pr/include/private -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 --coverage -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread -pipe -g -freorder-blocks -O2 -fomit-frame-pointer -funwind-tables -Wall -Wempty-body -Wignored-qualifiers -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat  -MD -MP -MF .deps/pripv6.o.pp   /builds/worker/workspace/build/src/nsprpub/pr/src/io/pripv6.c
[task 2018-09-28T16:07:08.326Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/nsprpub/pr/src/io/pripv6.c: In function 'Ipv6ToIpv4SocketAccept':
[task 2018-09-28T16:07:08.326Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/nsprpub/pr/src/io/pripv6.c:135:14: warning: variable 'rv' set but not used [-Wunused-but-set-variable]
[task 2018-09-28T16:07:08.327Z] 16:07:08     INFO -       PRStatus rv;
[task 2018-09-28T16:07:08.330Z] 16:07:08     INFO -                ^~
[task 2018-09-28T16:07:08.331Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/nsprpub/pr/src/io/pripv6.c: In function 'Ipv6ToIpv4SocketAcceptRead':
[task 2018-09-28T16:07:08.331Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/nsprpub/pr/src/io/pripv6.c:173:14: warning: variable 'rv' set but not used [-Wunused-but-set-variable]
[task 2018-09-28T16:07:08.331Z] 16:07:08     INFO -       PRStatus rv;
[task 2018-09-28T16:07:08.331Z] 16:07:08     INFO -                ^~
[task 2018-09-28T16:07:08.331Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/nspr/pr'
[task 2018-09-28T16:07:08.346Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/nspr/pr'
[task 2018-09-28T16:07:08.346Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/nspr/pr'
[task 2018-09-28T16:07:08.368Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.369Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/gcc/bin/g++ -o e_atanh.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DEXPORT_JS_API -DMOZ_HAS_MOZGLUE -I/builds/worker/workspace/build/src/modules/fdlibm/src -I/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation --coverage -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -freorder-blocks -O2 -fomit-frame-pointer -funwind-tables -Wno-parentheses -Wno-sign-compare  -MD -MP -MF .deps/e_atanh.o.pp   /builds/worker/workspace/build/src/modules/fdlibm/src/e_atanh.cpp
[task 2018-09-28T16:07:08.369Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.371Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.372Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.373Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.373Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/gcc/bin/g++ -o e_atan2.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DEXPORT_JS_API -DMOZ_HAS_MOZGLUE -I/builds/worker/workspace/build/src/modules/fdlibm/src -I/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation --coverage -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -freorder-blocks -O2 -fomit-frame-pointer -funwind-tables -Wno-parentheses -Wno-sign-compare  -MD -MP -MF .deps/e_atan2.o.pp   /builds/worker/workspace/build/src/modules/fdlibm/src/e_atan2.cpp
[task 2018-09-28T16:07:08.373Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.377Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.377Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.380Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.381Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.388Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.389Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.445Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.445Z] 16:07:08     INFO -  /builds/worker/workspace/build/src/gcc/bin/g++ -o e_cosh.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DEXPORT_JS_API -DMOZ_HAS_MOZGLUE -I/builds/worker/workspace/build/src/modules/fdlibm/src -I/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation --coverage -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -freorder-blocks -O2 -fomit-frame-pointer -funwind-tables -Wno-parentheses -Wno-sign-compare  -MD -MP -MF .deps/e_cosh.o.pp   /builds/worker/workspace/build/src/modules/fdlibm/src/e_cosh.cpp
[task 2018-09-28T16:07:08.446Z] 16:07:08     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-28T16:07:08.446Z] 16:07:08     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
Looks like code coverage builds need tweaking?
Component: General → Toolchains
Flags: needinfo?(mcastelluccio)
This is interesting, we are using the Nightly compiler for the ccov build: https://dxr.mozilla.org/mozilla-central/rev/024521c589d28744b5c4a6c01127fa35edef2c53/taskcluster/ci/build/linux.yml#1023.
Flags: needinfo?(mcastelluccio)
Ah, this is the opt build, which is not using the Nightly compiler.
I don't understand why this started failing only today.
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
Attachment #9012927 - Flags: review?(nfroyd)
Attachment #9012927 - Flags: review?(nfroyd) → review+
Pushed by mcastelluccio@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fbe8eaa6dbb3
Use Rust nightly toolchain for the Linux opt ccov build. r=froydnj
This is fallout from bug 1490948. That bug added a Rust crate in js/src, where we didn't previously have one. You're using unstable `-Z flags`, so you either need to be using nightly Rust (preferable) or the `RUSTC_BOOTSTRAP=1` hack we previously used to use simd before it stabilized:
https://dxr.mozilla.org/mozilla-central/rev/024521c589d28744b5c4a6c01127fa35edef2c53/config/rules.mk#903

I believe the issue here is that `MOZ_RUST_SIMD` isn't a `js_option` so it doesn't get set when building js/src, so you don't get the same `RUSTC_BOOTSTRAP` workaround you did previously.
Blocks: 1490948
(In reply to Ted Mielczarek [:ted] [:ted.mielczarek] from comment #6)
> This is fallout from bug 1490948. That bug added a Rust crate in js/src,
> where we didn't previously have one. You're using unstable `-Z flags`, so
> you either need to be using nightly Rust (preferable) or the
> `RUSTC_BOOTSTRAP=1` hack we previously used to use simd before it stabilized:
> https://dxr.mozilla.org/mozilla-central/rev/
> 024521c589d28744b5c4a6c01127fa35edef2c53/config/rules.mk#903
> 
> I believe the issue here is that `MOZ_RUST_SIMD` isn't a `js_option` so it
> doesn't get set when building js/src, so you don't get the same
> `RUSTC_BOOTSTRAP` workaround you did previously.

We're not using the RUSTC_BOOTSTRAP workaround for the ccov builds, we're using Rust nightly.

I was planning on switching to use RUSTC_BOOTSTRAP to keep the same version of Rust between normal builds and ccov builds. Why is it preferable to keep using Nightly?
(In reply to Marco Castelluccio [:marco] from comment #7)
> (In reply to Ted Mielczarek [:ted] [:ted.mielczarek] from comment #6)
> > This is fallout from bug 1490948. That bug added a Rust crate in js/src,
> > where we didn't previously have one. You're using unstable `-Z flags`, so
> > you either need to be using nightly Rust (preferable) or the
> > `RUSTC_BOOTSTRAP=1` hack we previously used to use simd before it stabilized:
> > https://dxr.mozilla.org/mozilla-central/rev/
> > 024521c589d28744b5c4a6c01127fa35edef2c53/config/rules.mk#903
> > 
> > I believe the issue here is that `MOZ_RUST_SIMD` isn't a `js_option` so it
> > doesn't get set when building js/src, so you don't get the same
> > `RUSTC_BOOTSTRAP` workaround you did previously.
> 
> We're not using the RUSTC_BOOTSTRAP workaround for the ccov builds, we're
> using Rust nightly.

Actually, for the ccov opt build, we were not using Rust nightly and we were not using RUSTC_BOOTSTRAP (so I'm not sure how it worked before).
https://hg.mozilla.org/mozilla-central/rev/fbe8eaa6dbb3
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
See Also: → 1495293
(In reply to Marco Castelluccio [:marco] from comment #8)
> Actually, for the ccov opt build, we were not using Rust nightly and we were
> not using RUSTC_BOOTSTRAP (so I'm not sure how it worked before).

You may not have been using it explicitly, but mozconfig.rust includes `--enable-rust-simd` so it gets applied to basically all builds anyway:
https://dxr.mozilla.org/mozilla-central/rev/7e9ab0e7b608ddb4d84f36194509f498c66e3449/build/mozconfig.rust#12

The change to add Rust compilation in js/src is what tripped things up.
You need to log in before you can comment on or make changes to this bug.