Closed Bug 1495286 Opened Last year Closed Last year

Constantly selecting all tabs when trying to pin a tab

Categories

(Firefox :: Tabbed Browser, defect, P1)

Unspecified
All
defect

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
geckoview62 --- unaffected
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 --- verified

People

(Reporter: darkspirit, Assigned: jaws)

References

Details

(Keywords: nightly-community, regression, ux-natural-mapping)

Attachments

(3 files)

mozregression --good 2018-09-15 --bad 2018-09-29
> 7:29.68 INFO: Last good revision: 839af7099c444d668f21ecad080c516c75e2c544
> 7:29.68 INFO: First bad revision: 634bcbff6b055a0d35e7cff7787121b62eb0063f
> 7:29.68 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=839af7099c444d668f21ecad080c516c75e2c544&tochange=634bcbff6b055a0d35e7cff7787121b62eb0063f

> 634bcbff6b05	Jared Wein — Bug 1480456 - Add 'Select All Tabs' into tab context menu. r=Felipe

Yeah, it's the "you've changed the position of a button and now I am getting crazy" problem. :D

I'm massively using the Pin Tab feature and now I'm messing things up.
Therefore I would like to propose a relocation and maybe greying it out
like the other "XXX All Tabs" if you only have one window with one tab open.
Summary: Constantly selecting all tabs → Constantly selecting all tabs when trying to pin a tab
Yeah, I think we can move this a bit lower since it's not going to be used as much as pinning tabs. Right now it's in the middle of the items, I think it can be moved to be the last item before the first separator.

Thanks for catching the other issue about the menuitem not disabling when there's only one tab. I'll fix that here too.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Priority: -- → P1
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #1)
> Thanks for catching the other issue about the menuitem not disabling when
> there's only one tab. I'll fix that here too.

I ended up fixing this part in bug 1480461.
Attachment #9013907 - Attachment description: Bug 1495286 - Move the Select All Tabs menuitem to right before the menuseparator and move the Bookmark Tabs item lower too to prevent breaking muscle memory. r?Felipe → Bug 1495286 - Arrange the tab context menuitems to maintain muscle memory as best as possible while also keeping the Select All Tabs menuitem high in the order. r?Felipe
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ab9ffb1f10de
Arrange the tab context menuitems to maintain muscle memory as best as possible while also keeping the Select All Tabs menuitem high in the order. r=Felipe
https://hg.mozilla.org/mozilla-central/rev/ab9ffb1f10de
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
I have reproduced this issue using Firefox  64.0a1 (2018.09.30) on Win 10 x64.
I can confirm this issue is fixed, I verified using Firefox 64.0b4 on Win 10 x64, Ubuntu 16.04 x64 and Mac OS X 10.13.6.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.