Search engine keyword/alias is highlighted inside URLs

VERIFIED FIXED in Firefox 64

Status

()

P1
normal
VERIFIED FIXED
6 months ago
4 months ago

People

(Reporter: adw, Assigned: adw)

Tracking

unspecified
Firefox 64
Points:
---

Firefox Tracking Flags

(firefox64 verified)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

(Assignee)

Description

6 months ago
(In reply to Bruce from bug 1491724 comment #5)
> Testing on 64.0a1 (2018-09-30) in WIndows 10, I noticed a small issue:
> 
> STR:
> 1. Give a keyword of `w` to the 'Wikipedia (en)' search engine
> 2. Type `w test` and press Enter.
> 3. Click on the url bar.
> 
> AR: `w` is briefly highlighted before the whole url is selected.

See bug 1491724 attachment 9013212 [details]
(Assignee)

Updated

6 months ago
See Also: → bug 1497515
Whiteboard: [fxsearch]
(Assignee)

Comment 2

6 months ago
This patch also fixes bug 1497515

Comment 3

6 months ago
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8411d22c2440
Don't highlight the search engine alias when the urlbar input doesn't match the first heuristic result r=mak

Comment 4

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8411d22c2440
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
status-firefox64: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
QA Whiteboard: [good first verify]

Comment 5

5 months ago
I have reproduced this bug with 64.0a1 (2018-10-01) (64-bit) on Windows 10 , 64 Bit ! 

This bug's fix is Verified with beta 64.0b8 !

Build   ID    20181108141956
User Agent    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

[testday20180914]
Thank you Sajedul! 

Based on comment 5 I will mark this issue as verified fixed.
Status: RESOLVED → VERIFIED
status-firefox64: fixed → verified
You need to log in before you can comment on or make changes to this bug.