Most recently used search engine keyword is highlighted on internal pages even without interacting with the urlbar

RESOLVED FIXED

Status

()

defect
P1
normal
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: bruce.bugz, Assigned: adw)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

(Reporter)

Description

6 months ago
STR:
1. Give a keyword of, say, `a` (without backticks) to any search engine, say, Wikipedia.
2. Type in the address bar: `a test`. `a` gets highlighted, and upon pressing Enter, you are taken to a Wikipedia page, as expected.
3. Now open some internal pages that have `a` in their address. So any about: pages would do. Extension pages would work too.

AR: First instance of `a` is highlighted in the urls of such pages.

Other things: This bug seems to be per-window. So if you opened a new window after STR2 and opened an internal page in it, the bug won't be reproduced. You will have to follow STR2 again for the new window too.
Drew, didn't you fix something like this recently?
Flags: needinfo?(adw)
(Reporter)

Comment 2

6 months ago
STR3 in my description is incomplete. Revised STR:

1. Give a keyword of, say, `a` (without backticks) to any search engine, say, Wikipedia.
2. Type in the address bar: `a test`. `a` gets highlighted, and upon pressing Enter, you are taken to a Wikipedia page, as expected.
3. Now open some internal pages that have `a` in their address, but without using the urlbar. E.g., open about:addons by pressing ctrl+shift+a, or hamburger > Add-ons. Any about: pages or extension pages that can be opened this way would work.

This should probably block bug 1491724.
(Assignee)

Comment 3

6 months ago
Yes, this looks like bug 1495614, which I filed based on another comment of yours, Bruce.  I'd need to investigate this a little more to say for sure and marking it a dupe.  Bruce, if you can confirm it's a duplicate in the meantime, then let us know.
Blocks: 1491724
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(adw)
See Also: → 1495614
(Assignee)

Updated

6 months ago
Assignee: nobody → adw
Status: NEW → ASSIGNED
Priority: -- → P1
(Assignee)

Comment 4

6 months ago
Also I doubt this has anything to do with internal about: pages.  It's probably just a dupe of bug 1495614, as I said.
(Reporter)

Comment 5

6 months ago
I had decided to file a new bug because I thought that the STR are quite different: here, the keywords retain their highlight even when not interacting with the urlbar, unlike bug 1495614. I don't know if the two bugs are exact duplicates or just related.
Whiteboard: [fxsearch]
(Assignee)

Comment 6

6 months ago
The patch in bug 1495614 fixes this, and after having written it and understanding this bug better, I think it's probably right to keep these bugs separate.
(Assignee)

Comment 7

6 months ago
Fixed by bug 1495614, closing
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.