MathML turns all math chars into Greek

RESOLVED WORKSFORME

Status

()

Core
MathML
--
major
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: jsmith, Assigned: rbs)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

When accessing any web page containing MathML, and running under RedHat 7.3,
Mozilla hangs for a long time (>30 sec). Just as I'm about to kill it, it
displays the web page, but all of the mathematics characters (including the ones
normally displayed in a roman font) are turned into Greek letters

Reproducible: Always
Steps to Reproduce:
1.Just access the MathML Start Page, running under RedHat 7.3.
2.
3.

Actual Results:  I could show you a screenshot...
(Assignee)

Comment 1

15 years ago
> I could show you a screenshot...

Please do.


Do you get a message about missing MathML fonts?
If not, did you install the *Type1* TeX fonts (not TrueType)?

Comment 2

15 years ago
Confirming.

I have installed all fonts recommended by the mozilla.org mathml page. I get a
dialog box the first time I open
http://www.mozilla.org/projects/mathml/start.xml saying "this page will not
display correctly if you don't have these fonts: ..." and the math displays in
greek letters.

xlsfonts doesn't seem to list any of the fonts that I've installed, which is
odd. I have restarted the machine after font installation.

(I don't get the 30 second hang though)

Screenshot coming up...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
Created attachment 90180 [details]
screenshot of greek letters on mathml page
(Assignee)

Comment 4

15 years ago
> xlsfonts doesn't seem to list any of the fonts that I've installed, which is
> odd.

So it is a font installation problem, as evidenced by the weird look of the
radical symbol (bug 27860).

Also, if you are are using a TrueType Symbol, you will be running into troubles:
http://groups.google.com/groups?dq=&hl=en&lr=&ie=UTF-8&th=1453307737e2abc6

...And it has been reported that RH7.3 ships with a TrueType Symbol font by
default, and this may explain why you are running into troubles anyway.

================
I suggest you file a separate bug against the GFX Compositor component, and
provide a *non-MathML* document with a testcase containing:

  <font face="Symbol"> a b c </font>

According to bug 33127, this should render as "a b c", but from your
description, this is rendering as &alpha; &beta; &gamma; on RH7.3 because it has
a TrueType Symbol font by default.

It is important that you report such a bug with a HTML testcase (i.e., no MathML
at all to illustrate that the problem is non-MathML specific). This way, it will
get the proper attention of other module owners. Thanks.

Comment 5

15 years ago
Created attachment 98429 [details]
Testfile mathml and text alignment

Comment 6

15 years ago
Created attachment 98431 [details]
Screenshot mathml and text alignment

Comment 7

15 years ago
Same behaviour on Mac OS 9.0.4 with
Mozilla 1.1 Mozilla/5.0 (Macintosh; U; PPC; de-AT; rv:1.1) Gecko/20020826: roman
characters inside <math> are displayed as greek characters. Time until the page
is displayed is normal. 

Although, in one special condition the characters are displayed properly: if the
math is inside a <div style="text-align: justify"> </div> and _not_ in display
mode the roman characters are displayed properly. I've added a testfile and a
screenshot.

Yes, the characters of the symbol font are displayed as Greek.
Yes, there is a message that CMEX10 fonts etc. are missing as there are no free
TeX fonts available for the mac. But stretchy characters are displayed properly
using Mathematica fonts. 

(Assignee)

Comment 8

15 years ago
As a work-around _delete_ the math's font-family declaration in mathml.css. See:
http://groups.google.com/groups?selm=3D6EB021.8FC1A9FE%40maths.uq.edu.au

Comment 9

14 years ago
Perhaps you will find that swapping over Symbol and Times in the mathml.css will
work.

I dont know why this would work. But it does for me.

Updated

12 years ago
Depends on: 233114

Comment 10

12 years ago
I'm seeing this in a very recent build: Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.8b4) Gecko/20050917 Firefox/1.4

All chars are greek, MathML is unusable here... =( This is Debian system with
the latex-xft-fonts package installed. This package contains:

/usr/share/fonts/truetype/latex-xft-fonts/cmsy10.ttf
/usr/share/fonts/truetype/latex-xft-fonts/wasy10.ttf
/usr/share/fonts/truetype/latex-xft-fonts/cmex10.ttf
/usr/share/fonts/truetype/latex-xft-fonts/msam10.ttf
/usr/share/fonts/truetype/latex-xft-fonts/msbm10.ttf
/usr/share/fonts/truetype/latex-xft-fonts/cmmi10.ttf
/usr/share/fonts/truetype/latex-xft-fonts/cmr10.ttf

This package is currently suggested by the Debian mozilla packaging to get the
MathML fonts:

$ dpkg -s mozilla-firefox | grep latex
Suggests: mozilla-firefox-gnome-support (= 1.4.99+1.5beta1-2), latex-xft-fonts,
xprint

The problem is gone if I edit res/math.css to remove the "Symbol" font.

Is there anything I can do to help debug this?
Summary: MathML turns all math chars into Greek under RH7.3 → MathML turns all math chars into Greek

Comment 11

12 years ago
I had a truetype symbol font and I hadn't commented out the proper lines in
res/fonts/fontEncoding.properties. Now it's working. (Having MathML working in
linux is pretty complex!)

Updated

12 years ago
(Assignee)

Comment 12

12 years ago
nick, be sure to write something about it so that others who google can learn
from your own experience.
Same behaviour on Ubuntu Linux with Firefox 1.5.0.6
Errors reading mathml.css (line 65 and 432) : see javascript errors.
(Assignee)

Comment 14

11 years ago
Those who still see Greek letters in Firefox are likely using a distro with a TrueType Symbol font (rather than Type1). If so, be sure to edit your $MOZILLA_HOME/res/fonts/fontsEncoding.properties and UNCOMMENT these lines:

#encoding.symbol.ttf = Adobe-Symbol-Encoding
#encoding.symbol.ftcmap = mac_roman

to

encoding.symbol.ttf = Adobe-Symbol-Encoding
encoding.symbol.ftcmap = mac_roman

See also bug 128153 comment 81.
QA Contact: ian → mathml
Is this bug still present?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.