Status

()

RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: dylan, Assigned: dylan)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

6 months ago
We seem to be expecting different input than we're receiving.

Reference {"bounce" => {"bounceSubType" => "General","bounceType" => "...} did not pass type constraint "Dict[bounce=>Dict[bounceSubType=>Str,bounceType=>Str,bouncedRecipients=>ArrayRef[Dict[action=>Str,diagnosticCode=>Str,emailAddress=>Str,slurpy Any]],reportingMTA=>Str,slurpy Any],slurpy Any]" (in $_[1]) at /app/Bugzilla/Quantum/SES.pm line 108
    Reference {"bounce" => {"bounceSubType" => "General","bounceType" => "...} did not pass type constraint "Dict[bounce=>Dict[bounceSubType=>Str,bounceType=>Str,bouncedRecipients=>ArrayRef[Dict[action=>Str,diagnosticCode=>Str,emailAddress=>Str,slurpy Any]],reportingMTA=>Str,slurpy Any],slurpy Any]" (in $_[1])
    "Dict[bounce=>Dict[bounceSubType=>Str,bounceType=>Str,bouncedRecipients=>ArrayRef[Dict[action=>Str,diagnosticCode=>Str,emailAddress=>Str,slurpy Any]],reportingMTA=>Str,slurpy Any],slurpy Any]" constrains value at key "bounce" of hash with "Dict[bounceSubType=>Str,bounceType=>Str,bouncedRec
(Assignee)

Comment 1

6 months ago
Posted file GitHub Pull Request
(Assignee)

Comment 2

6 months ago
The problem is that some fields (like diagnostic code) are actually optional.
I fixed that, and also made the type checking more standard.
Merged to master.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.